Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi

I have a slight problem with my sportage, After a long drive i put the car in Park and the engine revs go up to 2500rpm or more. They eventualy settle after a bit of movment back to just under 1000rpm.

I have also noticed that the breaks are quite poor, you have to realy push the peddle to get the car to stop.

Could this be linked and where do i start looking to fix this?

just had the pads replaced and its still the same.
Fully serviced with new air,oil, plugs etc/

Any ideas?

On a run the car drives fine, starts first time and so far havnt had any other problems.
thanks
James
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,930 Posts
Idle problem: possible air leak..Check all vacuum hoses...EGR valve.
Also check clean the IAC (idle air control) valve.. located on the end of the large rubber air hose in the aluminum throttle body... They get dirty with carbon and stick. A litlle carb/choke cleaner and a soft cotton rag and possibly a plumber's flux brush will do the job. Push the bottom of the butterfly valve (round metal disk) in and clean the contact areas.
Your braking problem may be air in the brake lines or the proportioning valve(s) may be bad...Just not enough information to give a high probability answer..
Dave
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,692 Posts
A vacuum leak could be the cause of both conditions..

Illegal air causes high engine RPM, and lack of vacuum will cause poor brake boost... Use a vacuum gauge to diagnose... Philip
 

·
Registered
02 Sportage 4x4...66 Shelby GT350...70 Mercury Cyclone Spoiler
Joined
·
196 Posts
Agree with the others. Sounds like you have a vacuum issue. I would check out the booster, and the line going to the booster. Cheers..
 
1 - 5 of 5 Posts
Top