Kia Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Warning light on dash has come on.It's orange and is the shape of an engine.I think it's the engine management light.Does anyone know why it as come on and how do I fix it.Thanks in advance Tom.
 

·
Registered
Joined
·
153 Posts
The engine's ECU is trying to tell you that something is wrong. you must go to the dealer and get the ECU scaned for the error code.

You are lucky that you can drive it, the last time it happened to me (not in the Sorento) I had to tow it to the dealer.
 

·
Registered
2005 Sorento ex v6 automatic
Joined
·
537 Posts
mine came on even befor i purchased my sorento ex, it was the evap. canister and check valve. they air freighted them in for the next day.
also a loose gas cap will cause the check engine light to come on as well, as well as many more serious things.
when it went back to have them install the parts i told them the front brake rotors were bad and they also replaced them, no questions asked. :thumbsup:
 

·
Registered
Joined
·
2 Posts
Same thing happened to me. they had to replace the cannister control valve as it was bad. My 2003 sorento also has had two burned out headlights I think this is a real problem. I am really having second thoughts about this SUV.
 

·
Registered
Joined
·
17 Posts
Bad headlights and a bad valve are giving you second thoughts about the Sorento?? In the grand scale of things, these issues are pretty minor.

Those same problems could have occured with any SUV, or sedan or van regardless of make or model.
 

·
Registered
Joined
·
2 Posts
We have had the engine light on our sorento come on also. The dealer told us after putting fuel into the kia, we must turn the gas cap at least 3 clicks. I failed to do this one time and the light came on. It took about 3 days and the light eventually reset. Hope this helps.
 

·
Registered
Joined
·
1 Posts
Emision control warning light

Just like to confirm previous post. Bought car 2nd hand, put fuel in and warning light! We tightened 3 clicks, disconnected and reconnected battery. Everything OK. THANKS!


K6lmd said:
We have had the engine light on our sorento come on also. The dealer told us after putting fuel into the kia, we must turn the gas cap at least 3 clicks. I failed to do this one time and the light came on. It took about 3 days and the light eventually reset. Hope this helps.
 

·
Registered
2004 Kia Sorento
Joined
·
64 Posts
Yeah try the simpliest thing first, disconnect your battery and leave for couple of minutes then reconnect it back again. It worked on my Sorie once.:)
 

·
Registered
2006 3.5 Sorento 4x4
Joined
·
1,047 Posts
Only works on some codes otherwise you could defeat the EPA yearly emission testing you have in the US
 

·
Registered
2013 Kia Sorento EX V6
Joined
·
198 Posts
Actually the quickest way to clear the CEL is to pull the P/TRN fuse in the junction box for a minute, while the Sorrie is off and push it back in...if it comes back get yourself a scanner far cheaper then the stealership would charge you to check the codes, but in most cases I've seen the CEL light come on is for the MIA Sensor of the gas cap not being on there tight enough...always do 3 clicks when tightening that gas cap. CEL light alone won't account for a serious event on your sorrie it's a Warning ABMER light...nuf said.

After you pull the P/TRN fuse and start the Sorrie your RPM's will jump and than settle back down so don't be alarmed. And this would be a good time to re-train your tranny to shift how you want it...me it was simple I took it out on the HWY stopped on the side of the road pulled the fuse put her back in waited for the cars to clear and held it to the floor board until she was done all the gears...SHIFTS AWESOME now and with that short ram intake mmmmm what a sound!
 

·
Registered
2005 kia sorento lx
Joined
·
64 Posts
had the same prob. called kia and was told that at 60000 mi. light comes on so you will get the spark plugs changed and have timing belt checked also.
 

·
Registered
Joined
·
1 Posts
ok i have a kia sportage 2001. was running perfectly. then had someone test drive it this morning and when they came back it ran lumpy, had no guts, missing, and had a green light (which i have never seen before ) come up on the left hand side that looked like 4 wheels with small bar connecting them. The 4 x 4 is disconnected . am confused as she was driving like a dream yesterday. any help would be appreciated as i still have people wanting to view for buying.
 

·
Registered
05 Kia Sorento LX 4x4
Joined
·
280 Posts
ok i have a kia sportage 2001. was running perfectly. then had someone test drive it this morning and when they came back it ran lumpy, had no guts, missing, and had a green light (which i have never seen before ) come up on the left hand side that looked like 4 wheels with small bar connecting them. The 4 x 4 is disconnected . am confused as she was driving like a dream yesterday. any help would be appreciated as i still have people wanting to view for buying.
This is actually the part of this forum for the Sorento, not the Sportage, but your question can apply to either.

You said it's running rough, and the 4x4 is disconnected. You sure about the 4x4 being DISCONNECTED?, your symptoms sound like 4x4 (including the green light) is engaged. On dry ground, turning will cause a jumpy feeling, and if you have even slightly mismatched tires, will cause the same on straight line. Make sure your 4x4 is turned off, and see if this helps. If it doesn't, post your question in the Sportage part of the forum for the most relevant answers.
 

·
Registered
Joined
·
1 Posts
I have a 2003 Kia Sorento and when I pump gas into it it spits gas back out at me and it keeps shutting off pump like it is full, also it drives then it acts like gas gets shut off to it and dies, it usually starts back up but it did this last night and I had to have it pulled home and now we have a light that comes on and stays on "Emission Control System" light, this didn't happen until we looked at handbook and guy who pulled us home had hit some kind of reset button on right side of underhood and it started and keeps starting but but the malfunction indicator light stays on but car still starts
 
1 - 15 of 15 Posts
Top