Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Can anyone help me with a check engine light on dashboard? I changed the battery and the light appeared. I saw a message that said to reset codes, to disconnect battery ground for short time. In changing the battery, I reset it didn't I ? All fluid levels are good. Maybe I should try disconnecting again ? Confused. Thanks
 

·
Registered
Joined
·
147 Posts
When you re-connected the battery, did you connect positive first and negative last? Always do this in that order. You can disconnect the negative again, wait 5 to 10 minutes or turn headlights on while disconnected to zap any residual current, re-connect and check for engine light. If it is still there, go to a place like AutoZone and they will do a free code check. Post that code and we'll go from there.

Also, fill out your user profile in the "User CP" so anyone responding will know what vehicle you drive. It will help greatly.
 

·
Super Moderator
Joined
·
6,838 Posts
Please re-read your post... You posted in the "do it yourself" area (not the model/year areas) ...then ask yourself did I give enough information to get help? Like a model/engine/year/mileage ...We presume that it is a KIA being as you posted on this web site...
Mad Hamster was/is being kind by asking his way but we need to know information to properly help you...
Common mistake for newbies :)
Dave
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
3 Participants
DavesSpectra
Kia Forum
Kia Forums is a community dedicated to all Kia models. Come discuss the Kia Sorento, Rio, Sportage, Soul and more!
Full Forum Listing
Top