Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1997 Kia Sportage which idles rough and will not rev up. Have had a scan test/check done which showed the cam position/phase sensor was faulty. Ordered a new sensor which finally arrived after 4 weeks, fitted sensor, cleared ECU codes and started engine only to find it runs exactly the same and logs the same fault code. Have fitted another ECU with still the same fault code logging. The TPS and AFM both seem to be working correctly and log codes if the plugg is removed from them while the engine is running. I NEED SOME HELP WITH WHAT TO DO NEXT. Has anyone any had this fault or a similar problem? Hope to hear from someone with an answer soon. Cheers, frustrated Sportage owner.
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts
Originally posted by faulty sportage@Jan 12 2005, 06:43 AM
I have a 1997 Kia Sportage which idles rough and will not rev up. Have had a scan test/check done which showed the cam position/phase sensor was faulty. Ordered a new sensor which finally arrived after 4 weeks, fitted sensor, cleared ECU codes and started engine only to find it runs exactly the same and logs the same fault code. Have fitted another ECU with still the same fault code logging. The TPS and AFM both seem to be working correctly and log codes if the plugg is removed from them while the engine is running. I NEED SOME HELP WITH WHAT TO DO NEXT. Has anyone any had this fault or a similar problem? Hope to hear from someone with an answer soon. Cheers, frustrated Sportage owner.
id replace the maf sensor, plugs and wires see where that gets ya. also might as well get the iat sensor while you at it that one is cheap...



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
349 Posts
If the ECM is still flagging a bad camshaft position sensor then I would suspect the wiring between the sensor and the ECM. I have that section of the electrical manual. Send me an e-mail at [email protected] and I'll forward it to you.

Just keep in mind that the data I have is for LEFT hand drive. It might be different for RIGHT hand drive.
 
1 - 3 of 3 Posts
Top