Kia Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
i just got an eletrical problem on my "KIA SEPHIA 2001"
the car is not charging, and noticed that on the dashborad display when switching the ignation on position, there is no check Engine break & charging lights showing.

your help is highly appreciated
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,467 Posts
Did you actually have the system checked? KOEO (Key On Engine Off) is one way to test the lamps. If the alt is actually charging then you might have a blown dash bulb.
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,128 Posts
Good advice above start with the simple things then if those are ok work up the list
Is the battery dead? A battery can go flat where it can't hold a charge. Have you had it tested? If thats not it maybe you need a new alt. There isn't much else that keeps the battery charged.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5 (Edited)
Thnks guys,

the dash bulbs was working before two or three days ago the system checked and found no charging, when removing the battery terminal while the car running the vehicle turned-off. the mechanic removed the alternator and replaced the carbon brass but still no respond yet then mechanic said that it might be the cut-out relay the one back side the alternator.

but i'm confused now, what i now if the alternator is not charging the battery bulb will switch on not disappear.

the battery cheched and recharged & found good. i return it back in the car and went around 15 to 20 Km and then the battery become flat again especially at night because using the lights. Immediately the car turned off due to have no enough battery power then i hve to recharge the battery again!
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,128 Posts
Thnks guys,

the dash bulbs was working before two or three days ago the system checked and found no charging, when removing the battery terminal while the car running the vehicle turned-off. the mechanic removed the alternator and replaced the carbon brass but still no respond yet then mechanic said that it might be the cut-out relay the one back side the alternator.

but i'm confused now, what i now if the alternator is not charging the battery bulb will switch on not disappear.

the battery cheched and recharged & found good. i return it back in the car and went around 15 to 20 Km and then the battery become flat again especially at night because using the lights. Immediately the car turned off due to have no enough battery power then i hve to recharge the battery again!
Just because you charged the battery, don't make it new again. How old is it.
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,128 Posts
1 - 9 of 9 Posts
Top