Kia Forum banner

1 - 20 of 21 Posts

·
Registered
2013 Sorento EX V6 Luxury
Joined
·
29 Posts
Discussion Starter #1
Does anyone have problem with the Green ECO light not turning on when the car is cold? My 2013 EX V6 has this problem, i even checked the mode and it says ECO ON and i dont see the ECO green light, i will have to depress it to OFF and ON an few times and then it comes on . Just wondering if this is normal and does your Sorento do this when its cold . Last week was fine when i started up the car and drove it immediately without even warming up the car.
 

·
Registered
2011 Kia Sorento EX V6 AWD & 2010 Hyundai Sonata SE
Joined
·
532 Posts
I believe it does this because the vehicle is still running a little rich during the first few minutes of startup/driving. Mine does the same thing. The ECO light might just actually do something but who knows.

That being said, Sometimes mine comes on right away, sometimes it takes extra long. It depends on the outside weather.
 

·
Registered
2013 Sorento, Suzuki V-Strom
Joined
·
506 Posts
Why is this a problem? What good is the ECO light? It merely shows that you aren't pressing too hard on the gas pedal for best economy, and your right foot should know this already.

Does anyone find the ECO indicator light beneficial for their driving?
 

·
Registered
2011 Kia Sorento EX V6 AWD & 2010 Hyundai Sonata SE
Joined
·
532 Posts
Why is this a problem? What good is the ECO light? It merely shows that you aren't pressing too hard on the gas pedal for best economy, and your right foot should know this already.

Does anyone find the ECO indicator light beneficial for their driving?
Kinda, not really. It does let me know that I am driving somewhat 'economical' so it is nice to have there....but at the same time it doesn't actually impact my fuel economy, regardless if it's on or off.

It's a personal preference I suppose.
 

·
Registered
2013 Sorento EX V6 Luxury
Joined
·
29 Posts
Discussion Starter #5
Thanks Rento Ex , for the answer and comparison. I guess its normal. Weird part is the light always worked even in cold weather like the extreme deep freeze we had two weeks ago here in TO. Unless i may be mistaken!
 

·
Registered
2013 Sorento EX V6 Luxury
Joined
·
29 Posts
Discussion Starter #6
Why is this a problem? What good is the ECO light? It merely shows that you aren't pressing too hard on the gas pedal for best economy, and your right foot should know this already.

Does anyone find the ECO indicator light beneficial for their driving?
Problem as in the Green Light not turning on regularly, (even though is in the ECO "ON " mode) , otherwise i don't see any significant changes to my mileage or performance or benefits! But it's good to know if you are driving aggressively or laid back .
 

·
Registered
2011 Kia Sorento EX V6 AWD & 2010 Hyundai Sonata SE
Joined
·
532 Posts
Yeah it did get quite cold here in Pickering a few days ago. I never really payed that much attention to the light when it does come on or isn't on. I would say the majority of the time it finally comes on is about 3-4 minutes into me driving.

I believe it's either connected to the O2 Sensors or the actual engine tem itself. Once the O2 sensors get a even reading(Not running rich at cold start) the ECO light starts to work as it should.
 

·
Registered
2013 Sorento ex luxury, 2014 Subaru Crosstrek XV
Joined
·
82 Posts
My Eco light comes on about the same time as the temp. guage comes off the bottom.
 

·
Registered
2013 Sorento EX V6 Luxury
Joined
·
29 Posts
Discussion Starter #9
Thank you for the replies and comparison. Just did not really want to take it to the dealer and always get the common answer " it's normal". So another weird problem i noticed was whenever i press the rear defrost button the engines shifts to a different sound like e.g when you turn on the A/C the engine gets more pull. My other cars never did this , Honda Pilot, BMW X3 and Town 7 Country . Does your Sorento do this?? (best is to hear in after the engine has warmed up and and is idling and try pressing and depressing the rear defrost button , you may hear a different noise coming from the engine!
 

·
Registered
2011 Kia Sorento EX V6 AWD & 2010 Hyundai Sonata SE
Joined
·
532 Posts
Thank you for the replies and comparison. Just did not really want to take it to the dealer and always get the common answer " it's normal". So another weird problem i noticed was whenever i press the rear defrost button the engines shifts to a different sound like e.g when you turn on the A/C the engine gets more pull. My other cars never did this , Honda Pilot, BMW X3 and Town 7 Country . Does your Sorento do this?? (best is to hear in after the engine has warmed up and and is idling and try pressing and depressing the rear defrost button , you may hear a different noise coming from the engine!
Yes. The defrost on most newer cars will turn on the A/C (even if the A/C light isn't lit) to help take the moisture out of the air.

What you're hearing is the A/C compressor kicking on.
 

·
Registered
2017 Sorento LX
Joined
·
104 Posts
Actually, cars have been doing that for quite a few years now, my 06 Sorento did the same, as did ones I owned before that. Not sure when they started it, but it's been awhile.
 

·
Registered
2012 Sorento EX V6
Joined
·
40 Posts
Just further confirmation, my eco light does not come on for a few minutes in cold weather. Never noticed before.:mellow:
 

·
Registered
Joined
·
8 Posts
Does anyone have problem with the Green ECO light not turning on when the car is cold? My 2013 EX V6 has this problem, i even checked the mode and it says ECO ON and i dont see the ECO green light, i will have to depress it to OFF and ON an few times and then it comes on . Just wondering if this is normal and does your Sorento do this when its cold . Last week was fine when i started up the car and drove it immediately without even warming up the car.
I just purchased a used 2013 with 19,000 miles. I noticed when cold the ECO light does take longer to come on but recently I noticed a lot of times it will not come on even after the engine is warm and miles of driving. If I pull over and turn the car off, restart it and then it will come on and work properly. I was going to ask the dealer about it since it is under warranty. It could be me but my imagination but it does not seem to shift as smoothly (or as often) when it's off and does not come on...I could be my imagination.
 

·
Registered
Joined
·
5 Posts
Eco Light Inop

I have a 2010 Kia Rondo 4 cyl. I have caused the eco light to malfunction by topping off the vehicle fuel tank. The first time it corrected itself a few days after the occurrence. However the last time this happened the light has stayed off. Does anyone know what corrective action is necessary to get it operational once again?

To answer your question, it's because I was fueling with cheaper American fuel and wanted as much as possible, and no I won't do it again.
 

·
Registered
Joined
·
8 Posts
Does anyone have problem with the Green ECO light not turning on when the car is cold? My 2013 EX V6 has this problem, i even checked the mode and it says ECO ON and i dont see the ECO green light, i will have to depress it to OFF and ON an few times and then it comes on . Just wondering if this is normal and does your Sorento do this when its cold . Last week was fine when i started up the car and drove it immediately without even warming up the car.
On the 2013 EX and LX Sorento, the light is only to tell you that you are driving more econonically. On My 2013 SX Sorento it is an active system and does affect the Transmission and shifting. It should take a few minutes for the ECO light to come on when cold until the engine reaches proper temp. I'm having an issue with mine that sometimes it does not come one at all until i stop the car and restart it. KIA says it's normal that it could take 15 miles or more but I know it's not and I am still pursuing the issue with them. Come on... I'm not stupid that an engine reaches normal operating temp in a mile or two and when it does work right it never takes more than 1.5 miles to come on.
 

·
Registered
Joined
·
8 Posts
Why is this a problem? What good is the ECO light? It merely shows that you aren't pressing too hard on the gas pedal for best economy, and your right foot should know this already.

Does anyone find the ECO indicator light beneficial for their driving?
True on the EX and LX but not True on the 2013 Kia Sorento SX. The ECO system is a live system on the SX. I have been having the same issues during cold weather and if it does not come on in the first 3-5 miles it will not come on until I pull over and turn the engine off wait a few seconds and restart the car. It immediately resets and works. I have had this to KIA many times with them saying no problem...BULL! There is a problem as I can tell the vehicle does act differently. They cannot find the problem and pretty much blow it off. To make matters worse, they told me that just because I opened a case on this under warranty that if it occurs out of warranty my "in warranty" complaints do not matter! GO FISH! I love the vehicle otherwise. Just the other day when I pulled over to "reset the ECO light", when I restarted, my radio and CD would not give any volume. When I pulled over the 3rd time on this trip and restarted, Low and behold, the radio started to have volume again. Seems like they still are having issues they cannot figure out or do not want to reveal! I also have another write-up on this site due to this issue. (p.s. the dealer told me this ECO on the SX was an idiot light too and not an active system. I used "Just Asked" paid the $12 or so $$ and a real KIA rep w/ 20 years experience as a KIA Mechanic and he told me there are issues. Showed that to the Dealer and they pretty much blew it off. I'm still not giving up on the issue. I have another appt. to get the radio and ECO looked at again. I'm sure another waste of time!
 

·
Registered
2013 Sorento, Suzuki V-Strom
Joined
·
506 Posts
Supra, thanks for the info.

By the way, you did not contact KIA. Not to quibble, but you contacted a private business that is a franchise of KIA. We don't know your location due to your blank profile, but KIA Canada is in Mississauga, Ontario. KIA Motors America is in Irvine, CA. They are KIA.

Try making a video of your car when you have the problem. Take the video into the dealership, ask to talk with the manager of the service department (not just one of the service writers), show him the video, and ask him to contact his KIA factory rep due to the unsatisfactory service you've received up to this point. Let us know how it turns out.
 

·
Registered
Joined
·
8 Posts
Supra, thanks for the info.

By the way, you did not contact KIA. Not to quibble, but you contacted a private business that is a franchise of KIA. We don't know your location due to your blank profile, but KIA Canada is in Mississauga, Ontario. KIA Motors America is in Irvine, CA. They are KIA.

Try making a video of your car when you have the problem. Take the video into the dealership, ask to talk with the manager of the service department (not just one of the service writers), show him the video, and ask him to contact his KIA factory rep due to the unsatisfactory service you've received up to this point. Let us know how it turns out.
Thanks for your info and feedback. I just saw your reply in July 2015. I actually did record this many times during the winter on my cell phone recording the light not coming on and then coming on after pulling over and restarting the engine. I put it on a flash drive for them to send to Corporate. They did send it back in May or June and in talking to them yesterday Corporate is still not sure why it is happening. Since then I now have been having it occur in warm weather but the ECO is not coming back on with restarting the engine. I live it PA and did call KIA Assistance Center (800-333-4542) but they referred me back to the dealer when I first had issues. The big difference now between what occurred in the winter cold verses the warmer weather is that when I restart the car, the ECO light may still not come on even after a couple stops for doing errands or just to pull over and restart. The KIA manager in Johnstown said they have enough of data to show the issue is occurring and did do a Tech line and have KIA Corporate involved. He mentioned that one possibility is to have a "flight" type recorder box hooked up to the vehicle (2013 Sorento SX (w/active ECO System) to see if that can find any issues. They did tell me now that even after 60,000 it would be covered as a warranty issue since I did bring this up without resolution. There are times like this week that I just pull out when the ECO light is not on yet since the engine is still cold but I can tell by the first time the engine tries to shift it is rougher shifting and then I know most likely that the ECO will not be coming on when it warms up. It is an issue with the shifting that does have a relationship with the light not coming on. When I notice smooth shifting, then most likely the light does come on. I can't believe I am the only one with this unique problem but have not seen any other complaints. I did speak to the previous owner who got rid of it and one of the reasons why was the shifting of the transmission. It is a wonderful vehicle otherwise. If anyone else has this issue and/or a resolution was found to fix, please sign in a reply! Thanks!
 

·
Registered
2011 Kia Sorento EX V6, 2006 VW Rabbit 2.5, 2003 Saturn Ion3
Joined
·
3 Posts
Just wondering if the ECO light goes out because the shifter is in manual mode? I notice that when it is in manual mode the ECO light goes away indefinetly until it is put back into D mode.
 
1 - 20 of 21 Posts
Top