Kia Forum banner

1 - 4 of 4 Posts

·
Registered
2010 Kia Rio LX
Joined
·
3 Posts
Discussion Starter #1
I have a 2010 Kia Rio. Recently it stopped running and we discovered that when I turn the key the ECU-C fuse would blow. Well come to find out my ECM is fried, I ordered a new one and its on its way but I'm a bit concerned that I will have to have the ecm reprogrammed? I got the part used on ebay and all the numbers matched up. Does anyone have any experience with this?
 

·
Registered
2011 Forte SX 2.4L (thankfully MPI) A/T 144K miles
Joined
·
1,438 Posts
If it's a brand new ECM from the factory, it will require a stealership to programmed it (and flush your wallet at the same time). But if it's a used ECM, then the VIN can't be changed, and you'll have to hope it runs 'asis'. But that' won't fly either, if you have emissions testing in your state.

Backing up a step, do you have any idea what caused the ECM to get cooked? If not, and that issue doesn't get fixed first, then there's a good chance the exact same thing will happen again to the replacement ECM at some point, if not immediately when it tries to start up.
 

·
Registered
2010 Kia Rio LX
Joined
·
3 Posts
Discussion Starter #3
I live in florida, we dont have emissions testing
at first we thought it was a short to ground somewhere, we got a diagram of everything and im pretty sure he tested every possible aspect. When he removed the ECM something inside was rattling around. Ended up being some big round piece i forgot what it was called but ive show a few people who all say it was cooked :/
 
1 - 4 of 4 Posts
Top