Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi
2012 Sorento LX, 73,000mi standard non navi type radio

Dead radio. Nothing on radio works, CD, BT, Sat, nothing. Will not power on. Have checked every single fuse inside dash and outside in engine, all fuses working (with ohm meter).

There is nothing else on the car that isn't working and this radio issue started all of a sudden.

Any ideas? I am trying to do some trouble shooting before going to dealership. They've gotten too much of my money in the past 3 weeks with an oil sensor change ($350) and broken parking brake cables ($800) and brake jobs. Tried of this.

This car is a good car, love the power and size, but quality wise I'm finding it to be crap. I've had more issues go wrong with it under warranty time as well as off warranty than I ever did with any other car I've owned.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Well, here is an update.

So the radio didn't work for about 3 days. Tried pulling all fuses in panel by driver side and all in hood area. No dice.
Disconnected battery, no dice.

Had to go out of town for a week. Car sat. Came back....radio now works just fine. What the heck?
 

·
Super Moderator
Joined
·
6,851 Posts
Parts in new electronics are surface mount and temperature or humidity changes can cause a part to become intermittent in connection...
Something like a voltage regulator IC chip may come loose and then no power will get to the rest of the radio circuitry and you'll get a "dead" radio...
Here's something to think about...
Because there are many people that like to "upgrade" to bigger better things radios identical to yours are available on Ebay pretty cheap...
Here is one with a starting bid of under $30 with a few scratches (you can exchange the front panels because they are socketed to the main board)
11 12 13 Kia Sorento Radio CD MP3 Bluetooth Sirius Player 96140 1U200 S00040 | eBay
If you have power to the "ROOM" fuse and the "Radio" fuse...then it's probably the radio on it's way out...
Dave
 

·
Registered
Joined
·
1,500 Posts
Hi there are two plugs on the back of the UVO/ radio one goes to amp the other power and controls. it may be worth checking they are In firmly possibly something disturbed when in for your break work.
Your hand book has the fuses and relays and their positions.

Jeff
 

·
Registered
Joined
·
6 Posts
Any help here? My radio, clock, and odometer have been resetting themselves as if there is a memory issue. Today the radio and clock were completely dead. Nothing is works at all on them! I even had my car alarm set off one day because the car didn't recognize my fob or key. I just bought the car 2 years ago and cannot afford to have all of these electric issues.
 

·
Registered
Joined
·
2 Posts
had same problem with my 2013 soul. first I noticed that a station, like 1130 am would not be heard unless you set radio to 1190!! all stations were off by 60. Then it completly died. Even the time did not display when radio turned off.

bought a used one at Amazon for $60. But ruined the sirius antenna recepticle trying to put it back on. no big deal , -- do not use it anyway.
 
1 - 6 of 6 Posts
Top