Kia Forum banner
1 - 7 of 7 Posts

·
Registered
2018 Kia Stinger GT1 AWD
Joined
·
5 Posts
Discussion Starter · #1 ·
I just purchased a pre-owned 2018 Stinger and I am trying to get it connected to my UVO Eservices account so I can use the phone app to set parking minders, remote start, etc. I've already registered it to my account with the VIN and have gotten a PIN from owners.kia.com in order to go into the "My Car Zone" settings. From there, I was told that I can use that PIN to go in and create my own PIN that will then link it to my account so I can use the app.

I have tried to change the PIN at least 100 times and keep getting the following error message: "Data was not transmitted. Please check your network connection. Would you like to try again?"

I am connecting my iPhone with a factory Apple cord. I've also tried multiple other cords and get the same result. I know data is transmitting through the cords since I'm able to use Apple Carplay so I don't think it's an issue with the cord or the USB port. There is no issue with my network connection either- I have service on my phone and also have the car connected to my hotspot.

I've contacted UVO support multiple times and they can't figure out the problem. They've told me to take it to the dealer because it is most likely a problem with the head unit. Has anyone else experienced this problem and found a fix? I really don't want to have to go to the dealer and be without the car for who knows how long just for them to charge me a ridiculous amount for something that could be an easy fix.
 

·
Registered
Joined
·
1 Posts
I just purchased my 19 stinger GT2 a few days ago and have this exact problem. I will add that I'm using Android with a pixel 5 and all other functionality with the phone works perfectly. Following in hopes of a solution.
 

·
Registered
2018 Kia Stinger GT1 AWD
Joined
·
5 Posts
Discussion Starter · #5 ·
I just purchased my 19 stinger GT2 a few days ago and have this exact problem. I will add that I'm using Android with a pixel 5 and all other functionality with the phone works perfectly. Following in hopes of a solution.
I’m taking it into the dealership on Saturday so I’ll let you know what they say!
 

·
Registered
2018 Kia Stinger GT1 AWD
Joined
·
5 Posts
Discussion Starter · #6 ·
I just purchased my 19 stinger GT2 a few days ago and have this exact problem. I will add that I'm using Android with a pixel 5 and all other functionality with the phone works perfectly. Following in hopes of a solution.
They determined that it was a problem with the head unit (radio) so they are going to completely replace it next week. Sounds like it was a complete malfunction and not just something that could be fixed.
 

·
Registered
2018 Kia Stinger GT1 AWD
Joined
·
5 Posts
Discussion Starter · #7 ·
The new head unit solved the issue (I also got a newer radio/navigation system out of it). But they cracked part of the dashboard trim while they were replacing it so now I have to have that fixed :rolleyes:
 
1 - 7 of 7 Posts
Top