Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hey guys,
Maybe I am missing something here but I cannot get the right/driver side CV axle out of my 04 Rio hub. There is no engine/transmission in the car currently so the axle is just sticking out in the bay. What is the trick to this? I have taken the axle nut off and I have tried hitting it with a mini slege hammer and the thing will not move. I loosend the collar around the ball joint and that did not help anything....do I need to take this off? Any help would be great! Thanks.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Nope. I have a parts car, so I am just going to take the whole hub/spindle off of that car and put it on this one. I already picked up a new axle....I just wanted to know if anyone else has ever had this problem and if I am missing something, because the axles came out of my parts car easy.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
What year is the parts car? Mine is an 02 and I don't remember anything needing extra other than the obvious. I think maybe a washer behind the axle nut, NOT 100% on that though. Brakes off?
THe parts car is an 05. I took the axles out of that car so I know how they are supposed to come out. Yesterday I ended up swaping the hub/spindle assembly over from the parts car so, I am good to go on that.
 

·
Registered
02 Kia Rio Automatic
Joined
·
17 Posts
Yeah,it shouldn't be stuck that bad... maybe the splines are screwed up. Shittons of deep creep and a sledgehammer should be more than enough.
 
1 - 6 of 6 Posts
Top