Kia Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I've had my an 03 CRDI auto for 18 months, and done 20k miles. Generally it's been an excellent car, but I have had one recurring fault that the dealer has been unable to fix (but they are still trying).

The problem is that the Cruise Control keeps disappearing.

Mostly what happens is that I'm cruising along, not touching any pedals, and suddenly the cruise cuts out, and the engine revs drop. Before I notice it, I've dropped 10 - 20mph. Bad news when towing a ton of caravan uphill. If I hit the resume button, then it picks up and takes me back to my usual 70mph. (60 when towing).

Other times, it's more of a nuisance. I'll be driving along with Cruise enabled (i.e Master button pressed) but not using it, look down and the green Cruise light has gone out. No amount of button pressing will bring it back. The only way I can make cruise available is to pull over, switch the ignition off completely, remove the key and start again.

There's no obvious pattern to when or why the problems occur. Sometimes it'll cover 500miles with no problems. Others it'll fail 3 times in 10 miles.

The dealer has replaced the control unit and the brake microswitch (twice), but the problem keeps coming back. I have sympathy with the dealer as they can't really perform any meaningful testing to prove its OK. Has anybody alse seen this problem, or got any ideas as to how to resolve it?
 

·
Registered
Joined
·
3 Posts
Hi,

I have a similar problem but much more reapeatable .. my cruse will not enguage and hold 60mph ... anoying when towing a caravan. All other speeds its fine.
 

·
Registered
Joined
·
153 Posts
I had a similar problem with a different cat, it turned out to be a faulty switch (the master switch), check them out.
 

·
Registered
Joined
·
5 Posts
Dicky_Mint said:
I've had my an 03 CRDI auto for 18 months, and done 20k miles. Generally it's been an excellent car, but I have had one recurring fault that the dealer has been unable to fix (but they are still trying).

The problem is that the Cruise Control keeps disappearing.

Mostly what happens is that I'm cruising along, not touching any pedals, and suddenly the cruise cuts out, and the engine revs drop. Before I notice it, I've dropped 10 - 20mph. Bad news when towing a ton of caravan uphill. If I hit the resume button, then it picks up and takes me back to my usual 70mph. (60 when towing).

Other times, it's more of a nuisance. I'll be driving along with Cruise enabled (i.e Master button pressed) but not using it, look down and the green Cruise light has gone out. No amount of button pressing will bring it back. The only way I can make cruise available is to pull over, switch the ignition off completely, remove the key and start again.

There's no obvious pattern to when or why the problems occur. Sometimes it'll cover 500miles with no problems. Others it'll fail 3 times in 10 miles.

The dealer has replaced the control unit and the brake microswitch (twice), but the problem keeps coming back. I have sympathy with the dealer as they can't really perform any meaningful testing to prove its OK. Has anybody alse seen this problem, or got any ideas as to how to resolve it?
yes exactly the same problem but still no answer. Someone must have a solution
 

·
Registered
2004 LX 4x4 5 speed
Joined
·
106 Posts
In additon to the master switch on the dash board there is the cancel switch on the steering wheel and the slip ring contacts (clockspring) behind the steering wheel.
 

·
Registered
Joined
·
5 Posts
cruise control

I have exactly the same problem with an 04 plate. No dealer has a clue what to do. Have you resolved it yet. Any clues
 

·
Registered
Joined
·
5 Posts
cruise control

the latest suggestion i have heard is a faulty brake switch.There are , so I have been told 2 switches one for brake lights and one for the cruise control. the likelihood is that the cruise brake switch is faulty and does not connect properly. the suggestion is to try replacing it ???
 

·
Registered
Joined
·
5 Posts
cruise control

Kia are aware of this problem. The dealers have had a bulletin suggesting that a modified brake pedal switch is fitted. The switch is approx £ 8 and 1 hour to fit
 

·
Registered
Joined
·
1 Posts
cruise control problems

i had the very same problems with my sorento xs 04 model about 6 months after i bought from new. also i had a problem with the accessory outlets with no power,took it back to the dealer they traced it back to a faulty piece of the wiring behind the dash, wire replaced hey presto no problems now for three years.
 

·
Registered
Joined
·
4 Posts
Exactly the same problem here, but also I have 4x4 Low coming on, sun roof opening and rear wiper's doing wierd things. Dealer says computer shows no problem. My inlaws have same car but XE not XS they have 4x4 Low problem and lights going off on the Dash board. Just had second visit to Kia Service, told they had fixed, "it was due to the wiring of the TowBar", (This was fitted from new by a Kia Dealer). Before I got the car home the problem was still there.

This is my second Kia, I usually recommend them for the good value and reliability. I won't be recommending them any more. Does anyone know a good auto electrical engineer in the Midlands?
 

·
Registered
Joined
·
7 Posts
same problem w/ my 2006 Sorento, dealer replaced my cruise control board 2x, problem returns, now when it happens I just tap my brake pedal twice, and get back and set my cruise control again..
 

·
Registered
Joined
·
7 Posts
My 2007 XS is going in for the third time because the cruise control keeps disappearing, this time it went just as I pulled out to pass on the M6. This would now be classed as a Lemon in the States, we complacent Brits. EH! After 5 years this same problem exists are KIA ever gonna address this problem or will it take a Court case to resolve? Any ideas?
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,878 Posts
My 2007 XS is going in for the third time because the cruise control keeps disappearing, this time it went just as I pulled out to pass on the M6. This would now be classed as a Lemon in the States, we complacent Brits. EH! After 5 years this same problem exists are KIA ever gonna address this problem or will it take a Court case to resolve? Any ideas?
Depends to a certain extent on what you mean by "disappearing". Automatic or manual? If you were pulling out to pass, were you accelerating? There a couple of possible causes. Faulty brake switch being one (or even inadvertantly touching the brake pedal could possibly do it). There have been ecu updates issued by kia to correct issues with cruise control over time, so they are obviously doing something. Just had the latest update installed on my 08 auto and it has made a vast improvement in usability.
 

·
Registered
Joined
·
7 Posts
Sorry! by disappearing I mean it just trips out, no pedal touching and doesn't work again until a switch off and restart, but this time was a bit dodgy due to 60mph/24ft. Caravan and packed M6. Dealer says they've had no KIA directives about this problem and I didn't find any tech. bulletins but we'll see.
 

·
Registered
'03 Sorento EX
Joined
·
19 Posts
Vacuum powered cruise controls will always trip out when towing a trailer on uphill grades due to lack of vacuum. believe all Sorentos use an electronic cruise control with no reliance on manifold vacuum but there must still be a link between manifold air pressure and cruise control operation to prevent engine damage when "lugging" the engine. I suspect they will all cut out when a certain engine load is reached and the transmission has not automatically down-shifted in time to prevent lugging.

Of course, manual transmission models won't downshift for themselves...
 

·
Registered
Joined
·
7 Posts
Got the car back after 6 days Kia told the dealer to replace the accelerator pedal, so we hit the M6 Motorway again with Caravan in tow and hit the cruise control, after about 10 miles guess what? that's right, no cruise control, so I've decided to reject the car and request a replacement.
 
1 - 18 of 18 Posts
Top