Kia Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,

I have an 09 Sportage and my cruise control doesn't set any longer. Also, my ESC off light comes on shortly after I start driving. I've read in some other posts here that there were power losses and other things happening, but from what I can tell, these are the only 2 things happening.

I thought that there might have been something wrong with my brakes, so I replaced all 4, but the problem remains.

Is this just sensor issue or something more sinister? I have just over 37k miles on it now, so I'm not sure if this would be covered under the warranty.

Thanks for any help you can give me!

Frank
 

·
Registered
07 Kia Sportage 2WD, V6, EX
Joined
·
88 Posts
on the 06 (and others) there is a 6 dollar cruise control switch on the brake pedal that goes out. very easy to replace. there is a thread on this.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks fellas. Checking the brake lights is not the easiest task to accomplish. I'll be calling the dealer today!
 

·
Registered
Joined
·
14 Posts
on the 06 (and others) there is a 6 dollar cruise control switch on the brake pedal that goes out. very easy to replace. there is a thread on this.
mcrews, I have been searching for this thread with no luck. Any chance you could point me in the right direction?

Thanks in advance for the time. Have a great afternoon!

PS: My appologies for the bump of an old thread.
 
1 - 9 of 9 Posts
Top