Kia Forum banner

1 - 13 of 13 Posts

·
Registered
Kia Sorento 2004 3.5; MPI-DOHC; 4 Speed AT 2WD
Joined
·
5 Posts
Discussion Starter #1
Hello,

I have a Sorento 2004 with 90k miles not starting, it cranks and it does like starting but nothing. The first testing was spraying starting fluid in the admission and did not start. During cranking I press the gas pedal but still, I noticed a gas smell when cranking. So far I have checked for spark with positive result (video), I replaced cam and crankshaft sensors, checked the timing and it looks good, the timing belt doesn't look loose or broke, I have checked fuses and relays and they all look good, switched similar relays and they all worked, checked the gas pump and its delivering gas, checked the valve solenoid sensor and it clicks, No codes with two different scanners one a regular OBD and the other a pro scanner.

Any help would be very appreciated.
 

·
Registered
09 kia spectra ex,04 Neon,04 Chry. T&C, 08 Pontiac G6 gt
Joined
·
2,168 Posts
IF you are truly getting gas(and even starting fluid) at the motor AND getting spark to the plugs(did you pull and check them for wear?), it should fire up unless the timing has "jumped". NOT sure if this is the year that fell into the crankshaft keyway/bolt breakage problem that could be the cause.
Good Luck, as I'm not that familiar with other than the 2.0 motor (found in the Spectra's).
 

·
Registered
Kia Sorento 2004 3.5; MPI-DOHC; 4 Speed AT 2WD
Joined
·
5 Posts
Discussion Starter #3
Yes, I pulled them out and they don't look like new but sparking. I am assuming there is gas going to the engine because 1. pulled the hose coming from the pump to the engine and spilled gas and 2. when I pulled the spark plug out the smell was notable. one of them was wet.

It's really weird and frustrating.
 

·
Registered
09 kia spectra ex,04 Neon,04 Chry. T&C, 08 Pontiac G6 gt
Joined
·
2,168 Posts
Plugs may be gas fouled and engine internals in a "flooded" condition. CHECK your oil dipstick level and sniff it for strong gas smell.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,607 Posts
When last was the timing belt changed?

checked the timing and it looks good, the timing belt doesn't look loose or broke
Post pictures of the timing marks when they're lined up.

Cant really tell the condition of the belt by a visual inspection, unless its totally trashed.
 

·
Registered
Kia Sorento 2004 3.5; MPI-DOHC; 4 Speed AT 2WD
Joined
·
5 Posts
Discussion Starter #7
Has a timing belt but I don't know when was the last time they changed. No record about timing belt on free carfax, I assume it has never been changed. But, doesn't look broken or stretched.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,607 Posts
Has a timing belt but I don't know when was the last time they changed. No record about timing belt on free carfax, I assume it has never been changed. But, doesn't look broken or stretched.
At 90K miles, it would be more than luck if its still fully in tact and not lost a few teeth - not sure what mileage it had on when you bought it, and if you bought it with more than 60K miles it should have been the first job you do.

Photos of all the timing marks lined up will be very telling.
 

·
Registered
Kia Sorento 2004 3.5; MPI-DOHC; 4 Speed AT 2WD
Joined
·
5 Posts
Discussion Starter #9
ok, will do. Tomorrow I'll take pictures and I'll try to check compression.
 

·
Registered
09 kia spectra ex,04 Neon,04 Chry. T&C, 08 Pontiac G6 gt
Joined
·
2,168 Posts
Plugs may be gas fouled and engine internals in a "flooded" condition. CHECK your oil dipstick level and sniff it for strong gas smell.
Reason for this post...IF the oil level is way too full(from gas dilution) you may have an injector or two stuck open dumping fuel instead of metered,timed injection. This would also make for a no start if more than one injector is bad.
Reason for Timing belt questions is the engine is toast if it breaks. And if more than two or three teeth of that cogged belt are missing in one section, timing could be off far enough to also cause a no run condition.
Good Luck!.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,607 Posts
ok, will do. Tomorrow I'll take pictures and I'll try to check compression.
You don't mention if this was sudden death while cruising, or a failed start attempt, performance degraded over time, first hesitation and then died, .........?
 

·
Registered
Kia Sorento 2004 3.5; MPI-DOHC; 4 Speed AT 2WD
Joined
·
5 Posts
Discussion Starter #12
Thank you, I will check that tomorrow and update here!
 
1 - 13 of 13 Posts
Top