Kia Forum banner

1 - 8 of 8 Posts

·
Registered
2011 Kia Sportage AWD
Joined
·
5 Posts
Discussion Starter #1
my sprotage recently has been acting up..i have a clunk like it is skipping a coupl teeth when light
acceleratiom and turning...and now also it runs like a dog. I have hardly any horse power.it up shifts
all the way up hills it downshifts and it feels like its struggling. I have to use manual matic..
the weirdest thing is no check engine light... twice I had the cel light. it said vaccum leak..
I started engine and sprayed carb cleaner everywher to look for leak but no idle change.. maybe gas cap?
also car has 180000 miles ..it has rebuilt trans and everhting else original ..please help
thanks
 

·
Registered
2019 Kia Sportage. SX with AWD. 2.0L Direct Injected Turbocharged & Intercooled Gas.
Joined
·
954 Posts
Sorry, but there are way too many items that can go wrong creating your exact driveability issues.
Best to get thyself into the shop for a diagnosis. You don't need to go to a dealership, only a trusted local master mechanic. They have the proper computer equipment to pinpoint the issue and guide you to a resolve.
All we would be doing at this stage is hit and miss guess work.
Some others chime in, but its only a starting point for discussions.
 

·
Registered
2011 Forte SX 2.4L (thankfully MPI) A/T 144K miles
Joined
·
1,438 Posts
What was the actual code? If you want to DIY, 2 things you can start with are taking a look at the spark plugs, and also to use a realtime ODB data stream reader for a look at the live data (not a basic code reader).
 

·
Registered
2019 Kia Sportage. SX with AWD. 2.0L Direct Injected Turbocharged & Intercooled Gas.
Joined
·
954 Posts
Yep.......
 

·
Registered
2011 Kia Sportage AWD
Joined
·
5 Posts
Discussion Starter #8
What was the actual code? If you want to DIY, 2 things you can start with are taking a look at the spark plugs, and also to use a realtime ODB data stream reader for a look at the live data (not a basic code reader).
I will get the actual number of code tomorrow. But is was a vaccum leak code. And I believe it to be the gas cap because a sprayed carb cleaning all over the idlei g. Engine and the rpm did not change. Also the plugs ? ? Maybe. But no misfire. So I doubt that
 
1 - 8 of 8 Posts
Top