Kia Forum banner

21 - 32 of 32 Posts

·
Registered
2011 Sorento EX I4 FWD
Joined
·
2 Posts
So let me get this straight. When set to Auto, both the temperature out of the vents and the speed of the fan should change automatically according to cabin conditions? This is how my other vehicle works. This is not how my Sorento works.

From day one, only the temperature out of the vents would change accordingly, but the fan speed goes to a low setting and has to be adjusted manually.

Not knowing any different I had simply convinced myself that it was just a poor design. I like to set it in Auto mode, but then just adjust the fan speed myself. If this isn't the way it is designed to function, I'm happy, I'll have the dealer fix it at my next oil change.
Look at page 4-87 in the manual, defrost logic. Follow the instruction under automatic. This may fix your problem.
 

·
Registered
Sorento EX V6 AWD
Joined
·
11 Posts
I don't have the manual with me so I don't know exactly what that page says, but the issue doesn't have anything to do with the defrost. Rather, when setting the system to Auto, regardless of set temperature and cabin temperature, the fan speed goes to low and never changes.

This is with Defrost off.
 

·
Registered
2011 Kia Sorento SX AWD
Joined
·
17 Posts
Dealer installed new control unit today. Fan is working as expected.

Hopefully will continue to do so.
 

·
Registered
Joined
·
156 Posts
I have had problems with mine last summer and the Dealership even replaced the sensor seemed to work about a week then stopped. I found by accident that while the HVAC system is on when the engine is running that if I just completely turn it off for a minute then hit the auto button from the start it works. It will take a second or two for the sensor to get it's reading then set the fan to the appropriate level. It doesn't work if I just turn on the heat or AC then hit the auto button. Only from being turned off then hitting the Auto button and of course only adjusting the temperature. Not the Fan speed. It has now worked since last July without a problem this way.
 

·
Registered
2018 Sorento SX V6
Joined
·
24 Posts
I am now getting my whole climate control - At the dealership we compared it to a brand new soreonto and it worked just fine there - so there is obviously an issue with mine. I am also now getting a new seat back portion due to my lumbar electronic control not working at all.
 

·
Registered
Joined
·
7 Posts
2012 Optima Hybrid climate control air conditioner. I had a similar issue to some of you. I recently noticed that in auto mode the fan speed never went above the low setting but I could manually override the fan with fan speed switch. Because my vehicle was out of warranty by a couple weeks, I hit the message boards. I tried the suggested fixes, none of which worked. Then I remembered that someone had mentioned the fan speed drop when Bluetooth kicks in. I have plenty of issues with my Bluetooth so I thought this could be something. I did the radio reset by holding the AM/FM and Map buttons for 10 – 15 seconds. The radio reset and now the climate control works perfectly again. Keep in mind you will lose all your radio preset info when doing this. Curious if this will work for anyone else out there. It sucks that the dealership is replacing control units and temp sensors at a significant cost when there is a quick fix.
 

·
Registered
Joined
·
7 Posts
2012 Optima Hybrid climate control air conditioner. I had a similar issue to some of you. I recently noticed that in auto mode the fan speed never went above the low setting but I could manually override the fan with fan speed switch. Because my vehicle was out of warranty by a couple weeks, I hit the message boards. I tried the suggested fixes, none of which worked. Then I remembered that someone had mentioned the fan speed drop when Bluetooth kicks in. I have plenty of issues with my Bluetooth so I thought this could be something. I did the radio reset by holding the AM/FM and Map buttons for 10 – 15 seconds. The radio reset and now the climate control works perfectly again. Keep in mind you will lose all your radio preset info when doing this. Curious if this will work for anyone else out there. It sucks that the dealership is replacing control units and temp sensors at a significant cost when there is a quick fix.
 

·
Registered
2017 Sorento EX
Joined
·
1 Posts
auto climate

has anyone figured this out? My auto climate control just goes to the lowest setting and does not auto adjust itself according to the climate. It immediately goes to the lowest setting of fan speed.
I fixed it by pressing the front defroster button 5 times in a row. It seems to cancel the action of going back to defrost at every setting.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,151 Posts
I fixed it by pressing the front defroster button 5 times in a row. It seems to cancel the action of going back to defrost at every setting.
Using the below link, please add location and vehicle (year & model) to your User Account/Profile

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD


https://www.kia-forums.com/threads/update-vehicle-information.342909/#post-2012499


https://www.kia-forums.com/threads/forum-rules.27240/


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 
21 - 32 of 32 Posts
Top