Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
since we bought our 2000 sportage a tad shy of a year ago the check engine light has never illuminated when starting the vhicle. I know in most other newer vehicles I have driven the check engine light illuminates whn the key if first placed into the ignition along with the the other idiot lights. is KIA the exception or do i have a problem in my light circut?
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts

·
Registered
Joined
·
349 Posts
As mentioned the "check engine" light should come on when the key is turned to "ON" and then go off when the engine is started.

The bulb is either burned out...or....someone removed the bulb because they couldn't fix an ongoing problem. I've seen that before and then the person sells the vehicle to someone unsuspecting.

I'll bet someone removed the bulb. And I'll bet once you check that out you'll discover that you have a check engine light that stays on all the time. Believe it or not the engine computer is smart enough to know if the bulb was removed or burnt out. The ECM should set trouble code P1693. And there will probably be other trouble codes in there too.

Any local Autozone will do a trouble code scan for free. Get ALL the codes that come out and post them here. We can provide fixes.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
yeah I was thinking the same thing Axeman... as I said the light was on when I first bought the vehicle took it to the used dealer and they " fixed" it... I will do as you suggest and apreciate everything
 
1 - 4 of 4 Posts
Top