Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Please help
I've some problems with my 97sportage and most of those are solved after
reading this kia-forums, (clean IAC volve, TPS etc;.). Thanks alot. :)
But still remain one problem for quite some time since last year is check engine light. That light on when I speed up and will go off when I release acclerator pedal. I don't know what is the fault code and no one around here can check the code. Please help what is the possibility case or, how to read the code from signal
light (red led light flashing from bottom of rpm meter)? :(
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts
If you have replaced things and didnt reset the ecu this might be the problem.
disconnect the negative battery terminal and get in car and press the brake pedal in this will remove all stored codes. then reconnect negative battery terminal and start vehicle it might run a little rough as ecu is doing its start up test. as we removed all information from its memory! if check engine light comes back on after this point there is a problem.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thank you for your reply.
I've disconnect the battery for one week (car park at home, away for oversea trip).
It run smooth after reconnect. But when I speedup, that light comeout again for
while till I release accelerator pedal. That light off when I speed reach to 130km/h or above. No one around here can scan the fault code of kia sportage. Is there any way to check the fault code by myself? :unsure:
 

·
Registered
Joined
·
1 Posts
I am in Australia and have had my Kia Sportage 1997 FX for nearly 2 years and have had many problems the major one being that it was the same problem.

I did some research and found that it was to do with a faulty engine control module. I have not had the controol module replaced as yet and the light still comes on periodicallly but i have been assured that their is actually nothing wrong with the car and it is a fualty sensor.
 
1 - 4 of 4 Posts
Top