Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Kia Rio5 07, Chev Trailblazer 02
Joined
·
3 Posts
Discussion Starter #1
There is nothing I hate more that a car that is not running right. expetially when it's not even 5 months we own it. This is not the fist time I have problems with the car, theother problem thatis now fixed we could kind of make do with but it's fixed. Not to mention the not so nice e-mail I sent to the KIA dealer. Not toooo pleased with them.
So my wife called me at 11.45 pm last night on her way to work. She said the car was haveing trouble getting over 90km per hour on the highway and the check engine light is on. This is the second time this happens. The first time it just randomly went away after a day.
Any insite on my problem would be greatfuly apreciated. I need to go backto the dealer with a loaded gun and not just fireing blanks.
Thanks guys
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,476 Posts
:00000732: to the forum.


You need to post this in the appropriate model section. You need to give all the important info on the car. Your not going to get any useful help untill you tell us that.
 

·
Registered
Kia-Sorento
Joined
·
8 Posts
Not sure about Kia, but when this happened to me once, it turned out to be the Catalitic Converter was "clogged", and needed replacement. Your car is an '07, so sounds like a typical 6 or 7 year old issue. Worth looking into anyway.
 

·
Registered
2015 Sorento
Joined
·
364 Posts
You gave little to no info about your car, the general symptoms it gave one night, and a rant about you were mad about a differnet problem that was fixed. What exactly are you looking to fill your "gun" with before you go to the dealer... There are alot of things that can cause this, and if its an older used car... what are you expecting?
 
1 - 4 of 4 Posts
Top