Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Anyone have a link to a wiring diagram for the 2009 Borrego Brake lights? My center brake light works so I assume the switch is OK, but the ones on the body and tailgate don't light. The bulbs are good..The taillights (same bulbs, different filaments) work. Is there a fuse? I haven't found one listed.
 

·
Registered
Borrego 2009
Joined
·
74 Posts
I have the complete digital manual but it is late and I am busy tomorrow. When I check back tomorrow evening I will try to send it if required.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,780 Posts
I have the complete digital manual but it is late and I am busy tomorrow. When I check back tomorrow evening I will try to send it if required.
Using the below link, please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature


https://www.kia-forums.com/threads/forum-rules.27240/
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
I have the complete digital manual but it is late and I am busy tomorrow. When I check back tomorrow evening I will try to send it if required.
Thanks, I looked at it again this morning but without the wiring diagram I'm not getting anywhere...
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Resolved, but kinda weird (and somewhat stupid on my part). I made the mistake of starting troubleshooting with the brake lights on the tailgate which both had good bulbs but didn't light. I assumed the ones on the body were in the same condition and started chasing a wiring problem. Turns out that both the "body" bulbs were blown, but the tailgate bulb brake light filaments are never powered although the rear light filaments are. I don't know if that's normal or if my Borrego is missing a connection somewhere...
 
1 - 5 of 5 Posts
Top