Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
I have a 2009 Borrego that won't go into reverse or park. The speedometer doesn't work along with other gauges on the instrument panel. Also, instrument panel light is out and turn signals don't work. Is this all related? It all happened within one day.
 

·
Registered
2009 Borrego EX WHITE/2009 Borrego EX Black
Joined
·
7 Posts
I have a 2009 Borrego that won't go into reverse or park. The speedometer doesn't work along with other gauges on the instrument panel. Also, instrument panel light is out and turn signals don't work. Is this all related? It all happened within one day.
It looks like the led is gone. I heard that if the led of the position is gone, there is no sign on the panel.
No way to repair, without change whole panel assembly. :-(
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,793 Posts
I have a 2009 Borrego that won't go into reverse or park. The speedometer doesn't work along with other gauges on the instrument panel. Also, instrument panel light is out and turn signals don't work. Is this all related? It all happened within one day.
Welcome to the forum.

It sounds like one or more fuses have blown - best to get your owners handbook and test all fuses with a multimeter.


Please fill in your profile detail, .....at least location and vehicle.


.
 

·
Registered
2009 Borrego LX V6
Joined
·
11 Posts
Rear brake light sensor replacement

I had the same problem last year on my 2009 LX Borrego. I had to lock and unlock the door locks on driver side inside until the issue allowed the gear shift to be placed in park. Issue was same as you describe.

The fix was the rear brake light sensor replacement recall which Kia issued last year for the Borrego. I had replace the sensor twice both under the recall warranty.
 
1 - 4 of 4 Posts
Top