Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok so I recently took my car to a mechanic to have the Exhaust manifold replaced because it had a crack in it. When I got it back I noticed it smoking so I turned it off. The smoke was coming from underneath the car and the idle was dropping and raising without pressing the pedal. So I turned the car off and went to get a friend. When I tried to turn it back on the car wouldn't start. I noticed that the Camshaft POS Sensor wires were hanging down. (not like that when I took the car to the mechanic) I called him and he still has yet to get back to me of course. So I contacted many places only to find that the only way to get the wiring harness is to buy the entire engine wiring harness kit ($200 for knock off or $1000 for KIA) Any ideas on how I can put this back together so my car can be diagnosed to the other problem?I have 3 wires that have little metal connectors that slide over the other end but I have no idea what slot they go onto. One is orange the other 2 are black. :confused:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
I recently bought a coupling for it that came off another kia. Now im trying to pt the wires back together to the old wires but there is still the issue of which 2 black wires connect to each other.
 

·
Registered
Joined
·
36 Posts
Can you take a picture of what wires you have? Also, what car do you have?

If the cables are cut off from the sensor side you can still purchase the sensor as it comes with the cable and molex connector. If the wires are cut off from before the terminal from the engine side, you can repair the cables easily by yourself, or buy a Wire Reparation kit.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
esalas
Kia Forum
Kia Forums is a community dedicated to all Kia models. Come discuss the Kia Sorento, Rio, Sportage, Soul and more!
Full Forum Listing
Top