Kia Forum banner

1 - 6 of 6 Posts

·
Registered
2020 Kia Sorento EX+
Joined
·
393 Posts
Discussion Starter #1
I have about 3000km on my rio. Just yesterday a strange thing started happening with the brake pedal. When I go to depress the brake pedal to start the car, it is super stiff, like as if i had pumped it a few times before I went to start the car.

Anyone else having this type of issue?

I doubt it to be a safety issue, but seems that something must have changed for this to have come about all of a sudden.

Never seen this on any other car I have ever driven....
 

·
Registered
14 Forte SX Koupe,15 Soul EX,58 & 90 Rolls Royces,92 Mercedes 500SL
Joined
·
333 Posts
Yes mine is the same & I have 4500 km's.Almost feels wooden.I think it's the ABS or ESP programming.Mine has always done it & I have felt the same feeling on new Mercedes-Benz too.Maybe you just never noticed it before.
 

·
Registered
2020 Kia Sorento EX+
Joined
·
393 Posts
Discussion Starter #3
Yes mine is the same & I have 4500 km's.Almost feels wooden.I think it's the ABS or ESP programming.Mine has always done it & I have felt the same feeling on new Mercedes-Benz too.Maybe you just never noticed it before.
Interesting... but yes, i am 100% certain that this just started exactly 2 days ago, and did not do it at all for the first 3000 kms I put on the car... so it did indeed not happen from day 1.
good to hear that i'm not the only one with this behavior, but troublesome to hear that some cars have it from 0 kms, and mine only developed it at 3000 kms...
 

·
Registered
12 RIO 5 SX, 07 VW Passat 2.0L turbo 1952 Siata Diana
Joined
·
168 Posts
Normal for any car with vacuum assist power brakes. If the engine isn't running you have no vacuum, and consiquently no brake boost.
 
1 - 6 of 6 Posts
Top