Kia Forum banner

1 - 8 of 8 Posts

·
Registered
2012 Kia Sorento
Joined
·
2 Posts
Discussion Starter #1
So, both of the main brake lights are acting funny. The third up top is working as it should.

When the lights are turned off and you press the brakes, they light up but only as bright as regular driving lights. When the lights are turned on, they are on constant and not the normal running light brightness, they are bright like I am pressing the brakes.

Anyone ran into this before?

Thanks!
 

·
Registered
2017 Kia Forte
Joined
·
50 Posts
Keep in mind that I'm not a mechanic, but it sounds like a grounding issue to me. I'd check for a loose or corroded ground wire first. If that doesn't do the trick, pull the bulbs and look in the socket for rust or corrosion. That's about all I can think of. Good luck with it.
 

·
Registered
2015 Sorento EX V6 AWD Ebony Black
Joined
·
1,153 Posts
It sounds like what chuzz said, or check for corrosion in the sockets, clean, then spray some WD-40 on it, it displaces water!
 

·
Registered
2015 Sorento EX V6 AWD Ebony Black
Joined
·
1,153 Posts

·
Registered
2015 Sorento EX V6 AWD Ebony Black
Joined
·
1,153 Posts
  • Like
Reactions: jetech00001

·
Registered
2013 Sorento
Joined
·
1 Posts
had same problem on my 2013 Sorento found that the ground connection in the brake light socket was not making contact with the light bulb. In the socket side there is a brass spring the contacts the side of the bulb. This had collapsed inside the socket slot so it no longer make contact with the light bulb. I used a hook bent small paper clip to grab the brass spring contact and pull it out enough to make contact with the bulb. Works fine now. Note the ground contact spring is in a slot in the side of the bulb socket. good luck.
 
1 - 8 of 8 Posts
Top