Kia Forum banner

1 - 5 of 5 Posts

·
Registered
2016 Kia Sorento SX AWD V6
Joined
·
16 Posts
Discussion Starter #1
Hey Guys,
Im new here,
Just wanted to post this for anyone out there looking at or already owning a 2014 sorento with the Uvo Systems.
Basically,
I recently traded in my 2011 Kia sorento SX to a 2014 sorento sx 2wd.
I mean, lots of updates in the car, comes with many pros and cons.
One are that I feel that they backtracked was with Bluetooth streaming sound.
Back in my 2011 sorento I used to constantly use my iphone 5 running my spotify account through bluetooth, and honesty, this combo is Bliss.
The sound sounded decent enough not to bother most.
Not as high quality audio compared to a wired connection, but seriously not too shabby.
Now with the Uvo system I get this static compressed sound that is pretty much unbearable. right around the high frequencies.

After much research on the web and with the kia,
here is what I got.

1. Service found some tech notes that state there will be a static/compressed sound when streaming audio

2. when I called kia and talked to a technician, they said that the UVO system was tested with iphone IOS 6.0. Currently its at 6.1.2 and they have not tested with this OS and could have some incompatibilities.
So not to account that my 2011 kia had no issues with the same 6.1.2IOS..
Basically they could not give me any answer to whats going on,
and cannot tell me if a firmware could resolve this issue or not.

They Say I should just use the wired connection..
But unfortunately, the spotify app does not function as well when wired compared to streaming interms of playing songs.
It plays one song, then wants to switch to the phones Itunes each time.
so I have to switch back to spotify and chose another song and hit play for the system to catch on./.

Pretty much a pain.

Anyone here, has any experience with this or any insight as to any solutions or work around?
I would appreciated.

Thanks guys,
 

·
Registered
Joined
·
7 Posts
I have the same issue too... I have a 2014 Kia Sorento with the Uvo system, and the audio quality over bluetooth is pretty bad. I have tried this with 3 iphones - a 4S running iOS 7, a 5S running iOS 8, and a 6 running iOS 8. All three have the same distorted, static-y sounds for the high frequencies. Plugging directly in thru the Aux port produces great sound. I hope at some point Kia releases a firmware update to fix this.
 

·
Registered
Joined
·
1 Posts
I have a 2015 Kia Cadenza with the same issue. The Bluetooth static sounds absolutely horrific. I use Spotify. But regardless of the app I’m using, if it’s plugged in by USB and the car is on the “iPod” source, if I change songs forward the car will literally skip to the next song repeatedly without me doing anything. I’ll manually switch back to the original song I wanted to play, and it’ll start switching songs again on its own. I’ll have to go back to the same song four or five times before the car stops constantly skipping forward. It’ll play about 6-7 seconds of a song then skip to the next. Sometimes it’ll skip only once, and others it will literally keep skipping every 6-7 seconds until I unplug my phone. At that point the forward and backward buttons have stopped working completely like the system is messing up. It’s so aggravating. This also only lets me use the forward button on my steering wheel or radio to manually skip to the next song, and when I do that there’s a 2-3 second delay. The back button will start a song over but will never go to the previous song due to the delay. This only happens when it’s plugged in via USB - not Bluetooth. This leads me to believe there’s a hardware connection issue somewhere where the car is not seeing something and it’s freaks out. Bluetooth works flawlessly except for the terrible staticky audio. Anyone else experienced this? I’m afraid to take it to the dealer because I doubt they’ll be able to diagnose it and I’ll pay money for them to tell me “sorry, can’t help you”. The amount of money I paid for my Cadenza in 2015 is unjustifiable to the issues in the radio. I had a 2013 Veloster Turbo and the Bluetooth in it had the same problem - a ton of static. Why can’t Kia get it together? Our Camaro never once had any of these issues. I think Kia just uses cheap hardware and refuses to fix it.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,600 Posts
1 - 5 of 5 Posts
Top