Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi,

For the past few weeks, my sportage's awd warning lights up very intermittently. I took it to my dealership but no code was written on the computer box. Now it is more frequent, atleast 4x a week it lights on. No noticeable power loss or weird sound. Also, I tried to reproduce it but no luck. My current mileage is just 11k++ miles.

Any idea what is causing this?

i took a picture of it
 

·
Registered
2011 Kia Sportage SX - Clear White
Joined
·
484 Posts
That's very strange. Reading the manual the 4WD system warning light states:

When the ignition switch is turned to the
ON position, the 4WD indicator will illuminate
and then go off in a few seconds.
If the 4WD system warning light
illuminates, this indicates that there is a
malfunction in the 4WD system. If this
occurs, have your vehicle checked by an
authorized KIA dealer as soon as possible.

I am surprised that KIA can't figure out why the light is on..
 

·
Registered
Joined
·
966 Posts
Okay, I don't have a KIA 4WD, but I've had a few others. I would see if the 4WD is working by testing it out on soft surfaces. I assume you're referring to the locked 4WD. If you've ever used it, you may have used it improperly on dry pavement, possibly setting tension between the front and rear. The old way of fixing that was to back up maybe 50' and go forward again, repeating as needed. Otherwise, it may be just a switch problem. I guess you have flipped the switch a few times to see what happens.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Actually, I brought it back to the dealership to the and pinpointed the real problem. The rear differential motor is receiving an unusual higher voltage that causes it to not engage and flag it as malfunction.

Kia is replacing the whole assembly for free today and get my car back tomorrow. :)
 

·
Registered
2011 Kia Sportage SX - Clear White
Joined
·
484 Posts
glad to see they got it sorted out for you.
 

·
Registered
Joined
·
966 Posts
Hey, that's good to know and to file for future reference. If my next vehicle is an AWD Sportage, as currently planned, that knowledge might come in handy.
 

·
Registered
Joined
·
4 Posts
I have the same issue and kia can't find what is the issue. Did you have this on your dashboard? Hope i will manage to link the picture
 
1 - 7 of 7 Posts
Top