Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Recently, I had my mechanic change the fluid in my automatic transmission and when driving home from his shop, my car began to lose power as I hit the gas. The lights would dim, the radio would blank out. I took the car to autozone and they told me my alternator was bad, but I'm just wondering if it could be something else. It seems too coincidental that this would happen after a fluid change. Could the mechanic have spilled some fluid or disturbed wires that could cause bursts of power and power loss?

Thanks,
Mindy :(
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts
Originally posted by mindy@Jan 11 2005, 01:04 AM
Recently, I had my mechanic change the fluid in my automatic transmission and when driving home from his shop, my car began to lose power as I hit the gas. The lights would dim, the radio would blank out. I took the car to autozone and they told me my alternator was bad, but I'm just wondering if it could be something else. It seems too coincidental that this would happen after a fluid change. Could the mechanic have spilled some fluid or disturbed wires that could cause bursts of power and power loss?

Thanks,
Mindy :(
Its the altanator.... i doubt he couldve spilled anything on it as tranny on oppisite side as alt.+ alts way in back.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 
1 - 3 of 3 Posts
Top