Kia Forum banner

1 - 7 of 7 Posts

·
Registered
21 Kia Sorento SX Prestige X-Line
Joined
·
6 Posts
Discussion Starter #1
Hi again, I appear to have another unknown issue. The first 3 or 4 days, the auto high beam feature worked wonderfully. The past 2 days, they stay on and do not automatically switch off when an oncoming vehicle approaches. The "Auto" indicator still shows on the dash but the beams stay on and people keep flashing at me. So I've been manually turning them off and on. The only difference in the past 2 days is the car has been more frosty from sitting out overnight but even when I get to work and everything is well defrosted, auto high beams still just stay on. I'm perplexed....
 

·
Registered
2021 Kia Sorento Hybrid EX Gravity Blue
Joined
·
76 Posts
Clean your windshield lately? The auto high beams rely on the camera at the top of the windshield. Frost or other debris on the windshield will degrade the performance.
 

·
Registered
21 Kia Sorento SX Prestige X-Line
Joined
·
6 Posts
Discussion Starter #3
Clean your windshield lately? The auto high beams rely on the camera at the top of the windshield. Frost or other debris on the windshield will degrade the performance.
ahh it's at the top. I wonder if that's too high for the defroster to affect. I'll check that tomorrow when it's frozen again. Thanks for the advice!
 

·
Registered
2006 Kia Sportage EX 2.7L
Joined
·
106 Posts
Haven't seen this feature for a long time and I've missed it. Had a 1981 Lincoln with auto high beams. It worked very good.
 

·
Registered
2020 Sorento SX, 3.3L AWD
Joined
·
413 Posts
I prefer to manage my own lights, so when I had cars in the past with that feature, I never used it.
 

·
Registered
21 Kia Sorento SX Prestige X-Line
Joined
·
6 Posts
Discussion Starter #6
I never had a car that had this feature and at first it was freaky to say the least but since I travel a lot of back roads without street lights, I was rather enjoying it after a couple of days. But then it just stopped working.
 

·
Registered
2021 Sorento, SX-Prestige X-Line. Silver/Black
Joined
·
20 Posts
I never had a car that had this feature and at first it was freaky to say the least but since I travel a lot of back roads without street lights, I was rather enjoying it after a couple of days. But then it just stopped working.
The sensor is located up top behind the rear view mirror. If it’s frosted up it def won’t work.
 
1 - 7 of 7 Posts
Top