Kia Forum banner
1 - 14 of 14 Posts

·
Registered
2019 Sorento SX L (FWD)
Joined
·
490 Posts
Discussion Starter · #1 ·
Even with light rain (drizzle-mist) it will go to high speed wipe, then back to slow, then back high again. Only brief stops.

The only thing I can think of that may be the cause is the dashcam that I have mounted to the center of the front windshield, below the smart cameras...

Anyone know where the rain sensor/s are located ?
 

·
Registered
2020 KIA Soul Ex+
Joined
·
620 Posts
There is a section in the windshield, usually near the top or side of the rear view mirror. where the RSW portal is. Your camera cannot affect it unless it was mounted OUTSIDE and over top of the relevant area.

IMHO the RSW feature is useless anyways, bordering on outright dumb, and it is one of the first things I disable when I install aftermarket glass.
 

·
Registered
2019 Sorento SX L (FWD)
Joined
·
490 Posts
Discussion Starter · #3 ·
For me, it used to be perfect. I miss it. Of course it has not got much use this year, so far we have had 10" rain which is 1/3 the annual average.
 

·
Registered
Joined
·
191 Posts
If the windshield is hazed, sand blown, or imperfect, dirty, the rain sensor will be confused by the light deflection
 

·
Registered
2015 Sorento SX AWD
Joined
·
2,012 Posts
Turn it off or take it to a dealer for repair. Maybe top end windhshield shops can look at them but call first. Personally I like to set my delay wiping speed for my driving speed and conditions. Full on in light rain/drizzle wears the blade as well. Certainly not a desired option IMO.
Things like Auto Headlight or Auto Highbeam are more useful and work.
 

·
Registered
2019 Sorento SX L (FWD)
Joined
·
490 Posts
Discussion Starter · #7 ·
I agree that a variable delay would be preferable to the smart wiper function. I remember back in the late 1960's building a unijunction transistor circuit to add that function to my Pontiac.
 

·
Registered
2019 Sorento SX L (FWD)
Joined
·
490 Posts
Discussion Starter · #8 ·
Well what do you know? The 'auto' mode does have multiple delay feature and it even shows on the instrument panel as you select a delay. Unfortunately this does not work, probably never did - no wiping at all no matter the selected wait time.

But some good news, driving in today's drizzle the auto rain sensing is now working and very well. No crazy behavior like a few days ago.
 

·
Registered
2015 Sorento SX AWD
Joined
·
2,012 Posts
Really, sounds like the normal auto mode with the delay, which is all I have. Is over ridden by the sensor system. If it was turned off then the other may work as well.
 
  • Like
Reactions: steve807

·
Registered
2015 Sorento SX AWD
Joined
·
2,012 Posts
Yeah, thats what I do as I don't have the rain sensor. Setting the delay manually works well and heavier rain goes to low speed setting.
 

·
Registered
2019 Sorento SX L (FWD)
Joined
·
490 Posts
Discussion Starter · #12 ·
Really, sounds like the normal auto mode with the delay, which is all I have. Is over ridden by the sensor system. If it was turned off then the other may work as well.
It's the same switch - up all the way is Auto (meaning sensor system) , then down four or five clicks are delay times...

so far the Sorento is great, one warranty fix for headlight wig wag when new 3 years ago, No problems at all other than this recent intermittent fancy wiper function
 
1 - 14 of 14 Posts
Top