Kia Forum banner

1 - 2 of 2 Posts

·
Registered
2007 Kia Rondo EX V6
Joined
·
255 Posts
Discussion Starter #1
Ok seems like the car is now turning into a lemon after 73K. Now the sunroof, After having the Sunroof on tilt mode I decided to close it and I hear a load Pop or Snapped Sound...Now the Sunroof won't tilt up or down...if I hit the switch to send it back it goes no problem if I try to close it it goes to about 95 % closed and then automatically reopens back again fully...after countless times I was able to get it fully closed again but I am now pissed...any thoughts something broke in the motor ? or is this track related? I hate to drop the headliner to only diagnose it.
 

·
Registered
2007 Kia Rondo EX-V6 Luxury, 1990 Suzuki Escudo
Joined
·
254 Posts
Ok seems like the car is now turning into a lemon after 73K. Now the sunroof, After having the Sunroof on tilt mode I decided to close it and I hear a load Pop or Snapped Sound...Now the Sunroof won't tilt up or down...if I hit the switch to send it back it goes no problem if I try to close it it goes to about 95 % closed and then automatically reopens back again fully...after countless times I was able to get it fully closed again but I am now pissed...any thoughts something broke in the motor ? or is this track related? I hate to drop the headliner to only diagnose it.
My first thought is maybe something got into or onto your track. I think safety wise if it experiences resistance it will go back open, as if something (like a hand) was caught in it. There should be a shut down for the motor too (maybe fuse or overheat switch) if too much resistance is experienced. Since the motor seems to be working I would hope it is something on the track. Possibly dirt?

With one of the services I had done at Kia the tech used white lithium grease spray to lube just about everything. It turned into a very hard, dry mess only after a few months. Maybe it was poor quality or something as it didn't get stiff like lithium products usually get, it went rock hard! Our sunroof was making unusual noises when I had a look and discovered this. It took a while to clean the crap off. I lube it with silicone spray every once in a while and haven't had a problem since.
 
1 - 2 of 2 Posts
Top