Kia Forum banner

1 - 20 of 59 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Three dealers and a KIA rep say this is normal and KIA has no plans to fix. If I had the TSB number I might be able to get this problem fixed. :(
 

·
Registered
Joined
·
134 Posts
conniepr....sorry I do not have a TSB number for you. First read the posts under " piston slap" where I have tried to explain the sound and the general location where it appeared to come from. I went to my dealer and once they heard the sound (loud squeak only when applying brakes and front dips and when accelerating when front rises slightly), they immediately zeroed in on the front strut. No hesitations on their part. I have driven the car 5 days since and have heard nothing so far. Mine was quite loud (squeak-moan) at times. If your sound is similiar I would not take no for an answer especially if youn can demonstrate that sound at the dealer. BTW , I was not told at the dealer that there was a TSB. Good luck....keep pushing and make KIA honor its warranty.....please keep the forum informed as this is one way to keep ahead of some lazy dealers and KIA reps........
 

·
Registered
Joined
·
279 Posts
rayray you suck :p I cannot get mine fixed for a bit at least. well yours was a strut mine is a strut mount, slight difference. I'll retype the high points of what I know.

Cars built before 4/23/04 have bad strut mount design and make noise at slow speeds on uneven pavement. When applying brakes is not included on the info I have. I will try to get it scanned so I can post it for yall to see yourself. I'll still working on a TSB number, if I could find that it would be like finding a live Yeti!

Oh driver side door jam for build date, if before 4/23 then very likely problem, mine was built in Dec 03.
 

·
Registered
Joined
·
134 Posts
RDNK4RE.....ckecked the dealer workorder I received and it says noise coming from strut assembly (which I assume includes strut mount) but then goes on to say that the strut was replaced (no mention of mount). Therefore it is possible that the problem is not fixed as I have only driven the car a few days with no discernable squeak. But remember the squeak was not consistently making the noise before either. Anyway it seems that we all have shared infomation which may help us resolve any future problems with the strut/strut mount problem ( or others) in relation to the warranty. Mine was built in 11-03. Let's keep ourselves informed by sharing information as I am not always sure the dealer and/or KIA will ALWAYS conduct business in the customer's best interest. Keep in touch.....rayray
 

·
Registered
Joined
·
279 Posts
KIA corp is just like any corporation, its all down to the bean counters. If it costs less even for a short term, thats what they go with.

Instead of sending a whole engine that would just drop into my car they sent a short block, which is cheaper but they still had to pay the technician to strip the old and engine and swap all the needed parts over to the new engine. It takes allot longer to tear down and swap over heads, cams etc. then it does to drop in a whole engine, but a short block is cheaper on initial cost.
 

·
Registered
Joined
·
134 Posts
RDNK4RE......Yeah, you're right and that's why these kinds of forums are so critical so that info shared is leverage in dealing with the powers that be. I hope the tech knew what the hell he was doing when he put your engine back together because what I am finding is the following. The dealer I go to is a Lincoln-Mercury store with the KIA line added and while talking to one of the staff ( shuttle driver and main gofor was telling me that the two KIA trained techs have quit and who knows if working on a Lincoln or Merc has much carry-over :unsure: :unsure: :unsure: .But so far this dealer has been pretty straight with me and I really don't have a complaint as long as they continue to honor the warranty but I also plan on giving them all my maintenance/repair business as I really do keep up with all of the required stuff. I always like to develop a good relationship with the people who take care of my car...BTW....what happens to the warranty on your new engine????Do you start with the 5 yr/60,000 mile and 10 yr/1000,000 mile all over again...just curious.....regards....keep in touch....rayray
 

·
Registered
Joined
·
134 Posts
Hey conniepr.........what's happening with your repair????? :huh: :huh: Keep us informed, as maybe we can help a little anyway. regards........rayray
 

·
Registered
Joined
·
134 Posts
:( :( Well it's back !!!!!! A Christmas Eve gift....new strut OLD SQUEAK IS BACK!!!!! The same ole squeak is back with a vengence but I had a week of no sound at all....go figure??????????? Well it is back to the dealer next week !!! Wish I had the TSB # (if one actually exists)....anyway Happy :angry: :angry: Holidays..........rayray
 

·
Registered
Joined
·
134 Posts
:angry: Where is everyone???How are we going to fix things if nobody contributes???? :( :( Here is the lastest on my Amanti front end noise. The strut was replaced=did not solve problem. Ball joint replaced today=did not solve problem. I left car at dealer and a regional KIA rep is supposed to check it out today or tomorrow. We'll see. Tech says she still hears the noise eminating from the ball joint which was replaced today. Tech also suggested that maybe it can be sheet metal rubbing :unsure: :unsure: ?????? Dealer is trying though, I can't fault them ( at least now).....I will post when problem is fixed........rayray
 

·
Registered
2004 Kia Amanti
Joined
·
51 Posts
Mine has a klunking noise when you hit bumps. It is at the dealer today. They called and said the upper strut mounts are bad and so are the sway bar bushings. They have to order parts and reschedule it for next Monday. They said ther is no TSB for this, but when they called KIA and asked about it they were aware of it. I will post next week Tuesday what they did and if it worked.
 

·
Registered
Joined
·
134 Posts
Paul......first, my sound which is coming from the right front suspension area is not a clunk and does not become noisy at all when going over bumps of any kinds...it is a squeak and not a clunk. So far the strut and ball joints have been replaced and since the squeak is still present, it has now been determined that the upper arm bushings are bad. They have been on order for over three weeks and as of today have not arrived. So when (or if ) they arrive and are installed I will let you know what the results are. This issue must not be very prevalent as no one seems to be posting anything about it. But , so far , it is annoying but has not stopped me from enjoying the Amanti. And YES, please post what happens with your clunk and how it is resolved because I will guarantee you someone else will ask about the same problem some day and the both of us will have info and be the experts on what to tell the dealer.....LOL...LOL. Actually I thought there were a bunch of posts regarding front suspension noises but they seem to have died off......Let me know Paul.....Many regards........rayray.................. :thumbsup: :thumbsup:
 

·
Registered
2004 Kia Amanti
Joined
·
51 Posts
My dealer called and the parts are not in yet. They said to check back Tuesday. I hope this doesn't drag on.
 

·
Registered
Joined
·
279 Posts
Well a little update for rayray and everyone......

engine is fine ever since they replaced the block...

the dang strut mounts though..........they ordered the parts for the strut mounts when I brought it in for the engine that was before thanksgiving......the parts didn't show up until mid January........had the strut mounts replaced about a week ago or so and its exactly the same as before it honestly doesn't sound any better even with the new upgraded mounts and sleeves for the struts.

Now Paul I am hoping that they do replace your sway bar bushing, not end links.....the noise you discribe is the same as what I have which sounds exactly like a sway bar bushing, basicly a metal on metal heavy clunck. I have experience with it when I litterally lost the whole sway bar mount on 1 side on a different car and thats how I discribed it at the time.

I don't honestly know what is going on anymore, 1st the dealer tells me when I bring it in there's a TSB then there isn't then there's this on then that......I don't know.

I know the mount kit didn't work for me. After I install a new trans in another car I just bought I may take a closer look at the front of my Amanti.
 

·
Registered
Joined
·
134 Posts
:angry: I sure don't what the hell is going on with the front end noises on these Amantis..seems everybody has a different type noise with rumors that it is this or that but no one (dealer) seems to really know what the problems are and how to fix them. I have had struts replaced and BTW I was told that the struts come as one unit and do not have replaceable mounts, new ball joints and now bushings for upper arms which have been received 2 wks ago but won't work because I was told that the collars were missing so I am still waiting since early Dec. to get this ( in my case ) squeak fixed...I am beginning to get frustrated with the whole dam thing and my patience is waning quickly.....some type of common information must be available to the dealers by now and they should have some practical ideas on how to fix these clunks and squeaks by now.......one thing I have not done was to call KIA in So. Calif. or talked to a regional rep.....anyone done this ??????? :angry: :( :( ....this is taking MUCH TOO LONG!!!!!!!! thank goodness, the car can still be driven for I would hate to pay for a rental faor the past 2+ months.......I'll post any info I get from KIA So. Calif. or a regional rep.... :angry: :angry: :angry: So how about a bunch of us calling So. Calif offices of KIA and sharing ................pissed rayray!!!!!!!!!
 

·
Registered
Joined
·
279 Posts
This does suck...... if this wasn't a new car with a warranty and all I'd tear it apart myself and take a look, which I may do yet. The mount, at least what I had seen looked more like a rubber isolator and steel sleeve kit rather then a whole mount. If its 1 piece or not I'm not sure I have not bought my repair manual yet which would show it in an exploded view.

I do allot of "shade tree" mechanics I have a project camaro which seems it will never be done and I just bought a 95 escort wagon as a run about and dog car which needs a new 5spd that I am picking up today so I know my way around a car. Anything beyond maintenance I'd rather not do on my new cars though. Why pay for work they will do for free right. ;) That' what warraties are for. It would be nice to have had this fixed the 1st time or better yet the problem have never developed.
 

·
Registered
Joined
·
2 Posts
I have a tennis ball in a sleeve type knocking sound from the right front suspension. After the dealer tried to fix via replacing bushings and links the car developed a loud squeak from same area. Again brought car to dealer and dealer repaired squeak but still have knocking sound from right front end. Now when I brouht car back to dealer was told that a TSB was out but when I picked up car the dealer told me all is OK but after driving car the knock is still there. Any one know what the kix is. ???
 

·
Registered
Joined
·
134 Posts
:angry: :eek: So by repairing your car for a knock the dealer created the squeak that's been bugging the hell of of me for the past 3 mos with the same parts that are ordered for me to fix my squeak......GO FIGURE :mellow: :mellow: this whole dam situation shouldn't be so difficult to fix but for some reason Kia can't seem to get right :angry: BTW I stopped by another Kia dealer yesterday just to ask about this and talked to the service manager who said he had not encountered any front end problems with the Amantis yet ( this is a new dealer, about 5months old) but did say that they seen a bunch of electical problems ( was not specific) and awhole lot cd units fail.......his suggestion was to call Kia ( no surprise)....so if my parts ever arrive ( the ones that CREATED your squeak) then I guess I can look forward to a knocking sound to replace the squeaking sound :haha: :haha: RIDICULOUS :crying: :crying:
 

·
Registered
2004 Kia Amanti
Joined
·
51 Posts
No parts yet! It has been about a week and half so far. They called me Friday and said they were air shipping them Monday and to call them Tuesday to see if they came in. I will keep you posted.
 

·
Registered
Joined
·
279 Posts
as someone that has had these parts ordered and installed I can tell you right now it takes between 1-2 months to get them. For me about 6 weeks and of course as usual it was a special order just to get them.
 

·
Registered
Joined
·
134 Posts
Well I am not sure if we are talking about the same parts or not but I know I took thre car in the beginning of Dec. for the squeak and shortly after that a new strut was installed. Several wks later a new ball joint was put in and some time in early Jan. upper arm bushings were ordered and arrived three weeks ago only to find out that they were the wrong ones.....so this goes on and on....the end of Feb is my limit before I call KIA and make arrangements to speak to a regional rep!!!!!!The squeak has become more frequent and louder.......thank God it is not a part which would make the car undriveable or this car would have been sitting for two and a half months........you know I am going to call the dealer and Southern Calif. KIA headquarters TODAY....WHY WAIT ANY LONGER?????????
 
1 - 20 of 59 Posts
Top