Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I got a seemingly plug and play (pray) aftermarket headunit off of Amazon. Pretty straightforward. In theory, all you have to do is remove the radio, swap the vents over and then plug up everything. Unfortunately, it only gets power when I join yellow and red together, resulting in a constant on scenario. I have checked the fuse (and replaced) in the back of the deck. I've checked all related fuses under the dash and hood. Using a multimeter, I get 12v on yellow but nothing on red, even with the key in the ignition. What am I missing here?
118474

118475

118476


 

·
Registered
2020 Sorento EX+ V6 AWD
Joined
·
6 Posts
You're giving me flashbacks to when I installed a navigation head unit in my daughter's 2002 Accord ( Power Acoustik PDN 626B 6.2-Inch Double-Din in-Dash GPS Navigation LCD Touchscreen DVD Receiver with Bluetooth: Amazon.ca: Electronics and https://www.amazon.ca/gp/product/B0002BF09S/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1 ).

Did the wiring harness come with the head unit or was it a separate purchase?
I found it works best if you buy a metra wiring harness for your specific model which should make all the proper connections. The only additional wiring I had to do was tapping a wire into the reverse brake light to power the backup camera.

Crutchfield is a good resource when it comes to stereos, dash kits, and wiring harness information.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hi. Thanks for the reply. It is the one that came with the purchase. While I dont mind going the route of purchasing a separate harness it defeats the purpose of plug and play. Was that the route you ended up taking too?
 

·
Registered
2020 Sorento EX+ V6 AWD
Joined
·
6 Posts
Hi. Thanks for the reply. It is the one that came with the purchase. While I dont mind going the route of purchasing a separate harness it defeats the purpose of plug and play. Was that the route you ended up taking too?
Sorry for the late reply. The head unit we purchased just came with a mess of loose wires once it was plugged into the back. I had to buy a wiring harness for the car and it made everything function properly. I would check with the manufacturer and see what they have to say or check for a brand-name wiring harness on amazon.
 
1 - 4 of 4 Posts
Top