Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
Hello
Have a weird issue. If I set the fan speed knob on 1 or 2, the green AC light will not illuminate and only get warm air out of vents even though temp setting is on coldest. If I turn the knob to 3 or 4, the AC light does come-on and also cold air is coming through the vents. I had the freon level checked and it is correct, and there appears to be no leaks. Did anyone have this kind of issue and what would be the fix?

Thanks!
 

·
Super Moderator
Joined
·
6,849 Posts
Hi Gidner..
First welcome to kia-forums.com!

The question the way you posted it is like saying "I have a friend that is short of breath"
Without telling your doctor the sex/age/smoking habits/past health problems...etc...

We need information in order to help you get past "generalizations" in replies...
General location (country-state) Different designs for different countries.
Year of car
Mileage
Manufacturer (KIA in this case)
Model
Engine size 4cylinder/6cylinder/8 cylinder
Transmission Manual/Automatic
Any attempts to cure the problem (parts, diagnostics)

I have seen more than one type of HVAC (heating,ventilation, air conditioning) in the same year and model of KIAs.. and simple things like giving LX or EX or SX help also.

Generally I would be looking at a bad blower motor switch that limiting the amount of current available to the AC clutch....BUT....I could be wrong with the little info we got...
Dave
 

·
Registered
Joined
·
95 Posts
Discussion Starter #3 (Edited)
Sorry, thought my car/engine models showed-up next to my name...did not pay attention (it does on some other forums i belong to...Saab, chrysler).

Nevertheless, the vehicle is a KIA Sedona EX, 2005, 6-cylinders...has about 85,000 miles, automatic, US model (we live in in OH).

Haven't attempt to fix it yet. Just had freon level checked (was ok) and pressure check (also ok and no leaks).

Also, when the comressor kicks in (when speed selector is on 3 or 4), it actually rattles a little bit. Compressor does not kick-in when speed selector is on 1 or 2 (and the ac light does not come-on...only on 3 or 4 as i mentioned above).

Where would this blower switch be - behind the dashboard, behind the speed selector, I assume? Is this a common failure? I called a local KIA dealer and asked if this is a common failure, but they of course only answered that they would have to diagnose the car (at $100/hr)...
 

·
Registered
Joined
·
95 Posts
Discussion Starter #4
After the overwhelming number of responses, I thought I'd at least share with you all how to fix this if it happens to anybody else. I don't know if this was one of a kind problem or if there is poor quality with the fan speed selector knob/switch. Mine had a glitch inside, which caused it to not turn-on the a/c...just turning on the fan. Luckily, the knob/switch is replaceable. I went to a U Pull U Pay and removed the control unit, which has all 4 knobs and reinstalled in my car. Works great now. You can change just the speed selector switch too, but don't know if that is sold a separate item at KIA (I suspect that they sell only the whole unit with 4 knobs, at a very hefty price).
 
1 - 4 of 4 Posts
Top