Kia Forum banner

1 - 7 of 7 Posts

·
Registered
2011 Kia Sorento
Joined
·
140 Posts
Discussion Starter #1
Hey All,

Ive been having issues with my 2011 KIA Sorento, with 86K miles...

The Traction Control and Downhill Assist warning lights come on frequently and then occasionally the ABS. It usually happens during city/highway driving after about an hour of driving. That's everyday for me but for many of you, it would rarely be noticed.

My dealer replaced the Brake Light Switch after pulling codes ($166.73 with labor part is cheap). The problem is persisting. They may try adjusting it or replacing the sensor again.

Have any of you had this problem with your in or out of warranty 2011/2012 KIA Sorento? If you are a tech, any other ideas? I am out of warranty so I don't want the dealer throwing parts at it, if I can help it.

Also for your reference a PDF, this is common on older KIAs:

http://www.kia-forums.com/general-kia-non-model-specific-discussion/57311-brake-light-switch-safety-recall-campaign.html
 

·
Registered
2011 Kia Sorento EX
Joined
·
1 Posts
I have a 2011 Kia Sorento EX 4 cyl; bought it a year ago last June. It currently has 9000 miles on it and I just had a similar problem with mine.

Last Saturday, I was driving about 20 miles away and ABS, Downhill Assist and Electronic Stability light came on. I drove to the nearest parking lot, shut it off and started it and still the lights were on. Drove for a bit, heard and felt a slight thud under the center front part of the car..then the lights went off. Later, while driving, same noise and the lights came back on. They did that off and on throughout the day. When I got home, I called the dealership but, they were closed (Saturday afternoon). Later that evening, my car alarm went off while sitting in the garage..first time that has happened. By Monday, the lights were off and when I was able to talk to the service tech at the dealership, his advice was just to call if it happened again.

Now tonight, a week later and after no problems all week, I got in the car to start it and it won't start. When I push the brake and button, radio, clock, headlights, interior lights, and indicator lights for Immobilizer and MIL come on but nothing happens. When I just push the button a second time, it sounds like the motor is trying to turn on but, won't. All of the other indicator lights also come on that normally come on when starting. Of course, it is again late at night on a Saturday and the dealership is closed until Monday :mad:
 

·
Registered
10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Joined
·
1,412 Posts
You stated there were codes stored. What were all the codes? There are a lot more parts in the ESC/ABS system that could set codes.
 

·
Registered
2011 Kia Sorento
Joined
·
140 Posts
Discussion Starter #4 (Edited)
You stated there were codes stored. What were all the codes? There are a lot more parts in the ESC/ABS system that could set codes.
Spongebob, sorry for the late response. I was absent from things for a few weeks...long story.

At 69K miles the three lights came on...dealer "cleared codes, vehicle now operates as designed" (Actual codes not provided) As I approached 80K miles a couple moths later, the light comes on any time I drive over 2 hours....less than that and its very unusual.

Yes the problem still persists. At 85K miles, the dealer did not provide the codes which pulled up, but they charged $150.88 to pull codes and labor to replace the brake light switch ($15.85 part) This did not resolve the issue. The service advisor thinks we need to replace the switch again, he said the Sorentos are eating these switches, one needed a new switch at 300 miles and again at 7000 miles.
 

·
Registered
2011 Kia Sorento
Joined
·
140 Posts
Discussion Starter #5
On my third brake light switch, good to learn how to replace this yourself....very simple and $15 out the door for the part.

If the problem persists I will post again, hopefully with codes. Thanks guys!
 

·
Registered
2011 Sorento FWD v6
Joined
·
33 Posts
On my third switch as well. Let me 7 year old daughter change them for me......that is how easy it is to replace. "No warranty on electrical parts." says my dealer. I'm just glad I have the no-how to do my own maintenance, but this problem persists. Computer flags absolutely no codes. I guess I should start a new thread on my ordeal.
 
1 - 7 of 7 Posts
Top