Kia Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
History: 2007 Sportage V6. My wires car. I got in it other day and when i turned it on battery light came on and no power steering. In like 30 seconds light went out and steering restored. also a squeaking sound. Turns out this has been happening for several weeks, but she thought it would go away. I replaced serpentine belt and the steering and light issue have not returned. I also spun all the wheels and no squeaking.But the squeaking sound is still there, when AC runs.

Noise: I had hood up and noticed it only squeaks when AC is on. also it is pulsating were AC runs fast then slow.


Since i replaced belt and batt and steering are fine I am guessing tention on belt is fine. at least i think.

Any ideas or things to try?

thank y'all
 

·
Registered
2-2000 1-2006ALL SPORTAGES also 96 dodge van to transport dogs and 84 gmc snow plow.
Joined
·
340 Posts
The idler tensioner maybe weak or the bearing in it maybe going bad. Not keeping proper tension .
Remove belt / check for free movement of tensioner an free rotation of the pulley.
Also check for dirt in all the pulley groves an dirt or oil on the belt.
A squealing belt will wear out very fast/ avoid used the a/c until resoled.
There's all ways the possibility of the a/c clutch or compressor going bad.
Check the ez things first.
Chief
 

·
Registered
2004 Optima 2.4 EX, 2005 Yamaha R1 (street) 2001 GSXR 1000 (track)
Joined
·
1,017 Posts
Check the crank pulley to make sure it hasn't seperated. I've seen many times where the rubber in the middle of the dampener fails allowing the crank to rotate intermittently inside the belt pulley.
 
1 - 4 of 4 Posts
Top