Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello all, 2006 Kia Sedona 75K miles.I need your expertise on A/C keep blowing fuse. It started last week. I have changed the fuse it was Ok for a week now it keeps blowing the fuse. Do you guys have any idea? Your help is greatly appreciated. Thanks.
 

·
Registered
1999 Kia Sephia, 2016 Kia Optima SXL, 2019 Kia Soul Plus
Joined
·
1,110 Posts
Hello all, 2006 Kia Sedona 75K miles.I need your expertise on A/C keep blowing fuse. It started last week. I have changed the fuse it was Ok for a week now it keeps blowing the fuse. Do you guys have any idea? Your help is greatly appreciated. Thanks.
If you have the capabilities, you might chase down the wiring from the fuse to the A/C compressor. You'll have to see if there is high resistance in the wiring causing the fuse to blow.
 

·
Registered
Joined
·
5 Posts
i am having a similar issue. what is the likely hood that there is high amperage through the relay? would it make sense to start by replacing the relay?
 

·
Registered
Joined
·
2 Posts
I also have a 2006 Kia Sedona that has 120K on it and this started happening a few weeks ago. We traced it back to the a/c clutch. Once we replaced this piece, the a/c worked great and no mor eblown fuses.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,928 Posts
I agree with kdtwellmann...
I just got the AC going in my future daughter-in-laws Hyundai Tiburon... (was a "salvage" car)
The AC compressor had both a bad clutch coil and also was leaking around the pulley shaft...
Hyundai and KIA share many parts (and similar problems)...

I replaced the compressor/clutch, expansion valve, Shrader valves, "O" rings, and dryer pack.
Added 4oz of PAG46 oil, evacuated the system (pumped out air to a vacuum), and recharged...
Works super cold now...

The clutch coils tend to overheat and then the insulation (shellac) burns off and the coil windings short together... This lowers the resistance of the clutch coil and increases the amount of current being drawn (blows fuse)... In my case the overheating caused a buried internal "thermal fuse" to blow/open...
I could actually see the thermal fuse buried in the epoxy...I think the heat from the overheating coil damaged the shaft seals causing the refrigerant leak.

I'd suggest checking the freon pressure in the system before attempting to just replace the clutch coil... If you still have freon (pressure) then replace the clutch coil...

Watch this....
https://www.youtube.com/watch?feature=player_detailpage&v=eGYaM0_KEgc
Dave
 
1 - 5 of 5 Posts
Top