Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi I'm a new addition to the forum. My 97 sportage has been acting funny as of late. Sometimes when I try to use the power windows they don't work, I press the buttons and nothing happens. However Then next time I started the car (24hrs later) it works. Has anyone experience anything similiar also the inconsistency has spread to the fan.

Please help

Rick
 

·
Registered
Joined
·
4 Posts
Originally posted by Rick@Dec 3 2004, 01:19 PM
Hi I'm a new addition to the forum. My 97 sportage has been acting funny as of late. Sometimes when I try to use the power windows they don't work, I press the buttons and nothing happens. However Then next time I started the car (24hrs later) it works. Has anyone experience anything similiar also the inconsistency has spread to the fan.

Please help

Rick
Hey rick i have a 02 with the same problems and the dealer says theres nothing wrong, i know that all you have to do is check the switches with a muilti meter but they dont want to so thats what i am gonna do its all in the switch
 

·
Registered
Joined
·
349 Posts
If just the power windows fail but the blower still works then chances are the power window switch assembly on the driver's door panel needs to be pulled out and have the contacts cleaned.

If BOTH the power windows and blower fail to work at the same time then the problem is the ignition switch. Common fail point. And can get messy because the ignition switch is riveted to the steering column.

If your dealer still claims nothing is wrong and both units are failing as mentioned then have him try the ignition switch several times to see if he can replicate the problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
just wanted to thank axeman for the good advice concerning my power window heater problem. I replaced the ignition switch about a week ago and so far so good. Bought it from the dealer for $23.00.
 
1 - 4 of 4 Posts
Top