Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently bought a '96 sportage and can not get it to pass smog inspection in California. The meter that the smog place uses keeps showing that the sensors aren't ready. I was told to drive it (including the KIA dealer) which I have. 237 miles at highway speeds. Took it for a retest and the same thing. Ism there something I can do or that needs to be repaired. I need to get this car registered!:confused.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,866 Posts
bettep...
Welcome to kia-forums...

First thing I would suggest is to get the engine's trouble codes....
The "check engine light" (CEL) does NOT have to be ON for error codes to be stored and retrieved...You probably have a few...

Advance Auto or AutoZone will read the codes for you for FREE...
Ask them to print them out and ask them NOT to reset them..
Bring the codes back here and "our" Sportage owners (we have a lot of them) from 1995~2012 will start giving you LOTS of suggestions!

We'll be here!
Dave
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I looked at the print out that the smog inspection gut gave me. It says the OBD II test failed. Functional Incomplete Monitors. Can anyone help?
 

·
Registered
Caribou, Otter, Buffalo
Joined
·
2,696 Posts
I looked at the print out that the smog inspection gut gave me. It says the OBD II test failed. Functional Incomplete Monitors. Can anyone help?

Not until you do due diligence and get the CEL code..... Write the all down incl any pending...

If the CEL is illuminated the monitors will not set...or if a monitor is defective the ECU will stall and not continue with the Monitor test.. Philip
 
1 - 5 of 5 Posts
Top