Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I hope someone can help me diagnose this:

Yesterday afternoon while driving my 96 Sephia 1.8L, the radio started cutting out, actually going on and off (intermittent power out). When I turned off the a/c, the radio would come back on and stay on, when I'd turn the a/c back on, the radio would go off. Otherwise, it seemed to be running fine. But it just seemed like there wasn't really enough electricity to run everything properly...lights seemed a little dim, wipers seemed extra slow. When I got it home I turned it off, and it started right back up and the radio and the a/c seemed to work fine together.

This afternoon it started just fine, ran fine for about 10 minutes, then the radio started cutting out again. I parked it for about an hour and at that time it wouldn't start...not enough juice to turn the engine over. I got it jumped, and drove it about 15 minutes to home, and it ran well, though I didn't try the radio or the a/c. But it won't start again (not enough juice to turn the engine over). The battery is less than one year old and I think it is ok.

Any ideas of what the problem is?

Thanks!
 

·
Registered
Joined
·
138 Posts
Check your alternator. Most parts stores will do it free. You should get 12 volts from the battery with the engine off and around 14 volts with the engine running (alt working). By now your "new" battery might be dead too. If alternator is bad change the battery too. Oh before everything check your connections and make sure they are clean, esp your ground.
 
1 - 3 of 3 Posts
Top