Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have had my Forte for 3 months now and have roughly 3000 miles on it and the transmission failed on a business trip back from Dallas. I am now 6 hours away from home with very little help from Kia. Anyone else experiencing issues with the CVT transmission?
 

·
Super Moderator
Joined
·
9,541 Posts
I have had my Forte for 3 months now and have roughly 3000 miles on it and the transmission failed on a business trip back from Dallas. I am now 6 hours away from home with very little help from Kia. Anyone else experiencing issues with the CVT transmission?
Using the below link, please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature
 

·
Super Moderator
Joined
·
6,854 Posts
I'm surprised that KIA changed from a reliable 6 speed to a CVT transmission... They should KNOW that the CVT in the Mazdas and other cars has not been very reliable... I would have taken the standard 6 speed automatic... Well time will tell but with only 3k miles on yours it doesn't look good... Please keep us posted...

KIA should offer you room and board and a free loaner with a car this new... If the dealer your car is at doesn't I would call KIA America (corporation)...
Dave
 

·
Registered
Joined
·
82 Posts
Also have the 19 Launch Edition and has been trouble free including a 2800 mile round trip from Michigan to Georgia and back that took well over 10 days. Possible that you just have a strange one but it is hard to believe that Kia is not doing anything about it. We're on our 4th Kia (all leases) and there always seems to be some strange occurrence and Kia has always stepped up to the plate, from a cracked front camera on our Optima to a new but outdated map program in our Sportage. Kia has never let us down. Have you spoken with customer relations?
I don't think you'll find many answers here as I've posted a few other questions about the 19 Forte and no one seems to know.
My only disappointment with the tranny and cruise is that I can be doing 65mph and the tac is about 500-800 rpm's below what it is if doing the same speed with cruise activated. But no one one here can seem to explain that one either.
 

·
Registered
Joined
·
215 Posts
The tach thing is probably just programming. It might have been programmed to keep the RPMs a little higher, giving a bit more torque, so the car is more responsive on climbing hills.
 
1 - 5 of 5 Posts
Top