Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all, this my first post.

I have a really weird problem with the climate control system. It seems that the system is stuck/defaults to windshield defog mode no matter what settings I select on the controls.

For example, ill set the temp to 78 deg, set the fan to high and set the vent direction to foot/bottom. The system would work as programmed for about 3-4 seconds and then switch by it self to windshield defog.

This seems to happen only when the heat is on. With A/C is working, the system works fine.



I recently had a windshield replaced on the Niro. The original got cracked due to a pebble impact at around 80 MPH.

We had Safelite Glass replacement come to the house courtesy of our car insurance. I recall the guy really struggled to get the original windshield off. He said that Kia "over-pressed" the windshield to the frame and didn't leave him any space to work with. He resorted to using heavy duty windshield cutout wire to get under the adhesive.

Anyhow, any chance the windshield replacement process damaged anything? Sensors/solenoid valves, etc? He did remove wiper blades and housing around the bottom of the windshield.

Ideas?
 

·
Registered
Joined
·
34 Posts
This is a feature that can be disabled

Kia Niro : Auto defogging system : Windshield defrosting and defogging

To cancel or reset the Auto Defogging System

Press the front windshield defroster button for 3 seconds when the ignition switch is in the ON position.

When the ADS system is canceled, Indicator on the button will blink 3 times per 0.5 sec.

When the ADS system is reset, Indicator on the button will blink 6 times per 0.25 sec.
 
1 - 2 of 2 Posts
Top