Kia Forum banner

1 - 2 of 2 Posts

·
Registered
2016 Kia Rio
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Here it goes, my fuel gauge goes up and down randomly like a possessed demon. My cluster assemble flickers when it does it and this all happens when my tire pressure sensor turns on randomly. Car runs fine though. I'm asking since I know someone with a 2016 Kia rip and it does the same thing. It starts with the tire pressure light turning on and his dash cluster assemble light turns completely off. Give it a few minutes and it comes back on. The owner has ignored this for over 1 year with no driving issues. These 2 cars seem to show these problems when it it's the rainy season. Anyone else having these issues? The Sportage I would like to fix if anyone can point where to look.
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
9,934 Posts
Here it goes, my fuel gauge goes up and down randomly like a possessed demon. My cluster assemble flickers when it does it and this all happens when my tire pressure sensor turns on randomly. Car runs fine though. I'm asking since I know someone with a 2016 Kia rip and it does the same thing. It starts with the tire pressure light turning on and his dash cluster assemble light turns completely off. Give it a few minutes and it comes back on. The owner has ignored this for over 1 year with no driving issues. These 2 cars seem to show these problems when it it's the rainy season. Anyone else having these issues? The Sportage I would like to fix if anyone can point where to look.
2016 sportage

Using the below link, please add location and vehicle (year & model) to your Profile/Account Details

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/account-details


https://www.kia-forums.com/threads/forum-rules.27240/


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 
1 - 2 of 2 Posts
Top