Kia Forum banner
1 - 14 of 14 Posts

·
Registered
2016 Sorento SX
Joined
·
8 Posts
Discussion Starter · #1 ·
2016 SX AWD, so this has happened three times now, the first I put off as a fluke.

While driving in the dark, with the headlight switch on Auto and fog lights on, the lights turn themselves off and back on again faster than I can reach for the switch. Ive played with the multi switch, thinking maybe it was bumped and on the verge of being between off and Auto. It has a definite position, and is quite difficult to have it "in between" those settings. Anybody experience this yet? Its going back to the dealer soon for a faulty folding mirror, and now this....has me worried about electrical gremlins.

Matt
 

·
Registered
2016 Kia Sorento LX V6 AWD
Joined
·
641 Posts
2016 SX AWD, so this has happened three times now, the first I put off as a fluke.

While driving in the dark, with the headlight switch on Auto and fog lights on, the lights turn themselves off and back on again faster than I can reach for the switch. Ive played with the multi switch, thinking maybe it was bumped and on the verge of being between off and Auto. It has a definite position, and is quite difficult to have it "in between" those settings. Anybody experience this yet? Its going back to the dealer soon for a faulty folding mirror, and now this....has me worried about electrical gremlins.

Matt
Agree, the auto position is pretty firm and stable. What mods have been done to the vehicle thus far? Are both the fogs and the headlights turning off, so total darkness?
 

·
Registered
2016 Sorento SX
Joined
·
8 Posts
Discussion Starter · #3 ·
No mods, all factory settings. Total blackout occurs, including the dash. It almost seems like maybe the auto sensor?...perhaps it thinks it got bright enough outside to turn off headlights??
 

·
Registered
2016 Kia Sorento LX V6 AWD
Joined
·
641 Posts

·
Registered
2016 Sorento SX
Joined
·
8 Posts
Discussion Starter · #5 ·
interesting indeed!! thanks for finding that. Looks like another visit to the warranty department.
 

·
Registered
Joined
·
2 Posts
My 2017 Sorento has done this twice on a recent trip. Driving along at night and the headlights cut off while in the auto mode. I quickly switched the headlights on. After stopping I set it back to auto mode and it did it again a little while later.
 

·
Registered
2019 Sorento EX V6
Joined
·
926 Posts
Never had the headlight problem on my 2016 SX AWD.
The folding mirrors - YES~!
If the dash blacks out this is not a problem on the switch. The dash only blacks out when the ignition is turned off. Most likely a computer problem or a loose master plug.
 

·
Registered
2016 Sorento sx 2.0T
Joined
·
283 Posts
My 2017 Sorento has done this twice on a recent trip. Driving along at night and the headlights cut off while in the auto mode. I quickly switched the headlights on. After stopping I set it back to auto mode and it did it again a little while later.
Happened to me a couple of times. Not sure if it was a fluke,but I just turned the lights on and off a few times. I think it's the switch sitting in auto mode all the time probably gets crusty. Not sure about the total mechanics inside that dial, but I'm guessing there's some kinda contact points that might need a little scratching. Been months since its done it again. Little freaky tho when it does happens:eek:
 

·
Registered
2012 Sorento 3.5L
Joined
·
3 Posts
My 2016 Sedona is doing same thing now. I think it is a problem across Kia Line do a search on any Kia headlight problem and other models come up with same problem. The dealer can never "duplicate problem"
 

·
Registered
2017 Kia Sorento SXL V6 AWD
Joined
·
1 Posts
2017 sorento sxl limted. Same thing has happened to me a few times now over the past few months. In auto mode. lose all lights. only comes back on when i turn to off and back to auto or on.
 

·
Registered
2017 Sorento LX
Joined
·
178 Posts
I had the same issue, under warranty thankfully. Dealer replaced the light stalk.
 

·
Registered
2016 Sorento SXL
Joined
·
30 Posts
Check your negative terminal on the battery. I had this same issue with a Nissan truck, after much messing around it turned out to be the negative terminal was very slightly loose. Tightened it up and the problem never returned.
 
1 - 14 of 14 Posts
Top