Kia Forum banner
1 - 9 of 9 Posts

·
Registered
2014 Kia Rondo LX 5DR
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all, hoping to get some help on this one. I have a 2014 Kia Rondo that I've had parked for the last month and a half while self-isolating. I decided to take it for a spin around the neighbourhood to get it some movement, and after jumping the dead battery, I'm now hearing a 'clicking' noise from it (or stuttering). I have very little experience with cars, and due to my self isolation, I don't feel comfortable taking it anywhere for a long while yet.

The sound appears to be coming from the left side of the engine, I can't quite tell if it's front or back, but its definitely left side where the alternator and belt are, but that's as close as I can localize it. I don't see anything loose to cause a rattle.

I took some recordings to try and capture what I'm hearing

This is from the inside while driving around the neighbourhood: Vocaroo | Online voice recorder

This is getting up to speed on an on ramp to a highway (give it 15-20 seconds): Vocaroo | Online voice recorder

And this is the sound of it idle with my phone placed near the engine: Vocaroo | Online voice recorder

Is this something obvious? I have no warning lights on the inside, my OBDII monitor doesn't show anything out of the ordinary (it did show an emission leak somewhat recently, but it disappeared again, so may have just been a gas cap issue).

Thanks for any help!
 

·
Registered
2014 Kia Rondo LX 5DR
Joined
·
2 Posts
Discussion Starter · #2 ·
Done, though I'm not sure of specific engine information as I don't see it on my documentation.
 

·
Registered
2020 Kia Sorento SX, 2013 Hyundai Elantra GT Tech pkg. Former 2014 Kia Rondo EX Luxury,
Joined
·
430 Posts
-
 

·
Registered
2020 Kia Sorento SX, 2013 Hyundai Elantra GT Tech pkg. Former 2014 Kia Rondo EX Luxury,
Joined
·
430 Posts
-
 

·
Registered
2007 Rondo and 2000 Tacoma
Joined
·
185 Posts
It sounds like something is actually broken in the valve train. If you have 60,000 miles on the engine it’s due for a valve adjustment/check. If your due the valve cover has to come off, if anything was broken it would be obvious.
 

·
Registered
2013 Kia Rio Sedan Auto 1.6 Turbo // 2020 Sportage LX FWD
Joined
·
445 Posts
Bad news. Piston slap, was told $4000 to fix. Was reported to the dealer with 500kms after warranty expired and told warranty won't cover it.
Get a second opinion.
 

·
Registered
2007 Rondo and 2000 Tacoma
Joined
·
185 Posts
I might be way off but I read the GDI engine ( if you even have a GDI ) has a second high pressure fuel pump under ( or maybe near ) the valve cover and it can make a metallic sound if going bad....If that’s accurate you might want to investigate further. A lot cheaper than replacing pistons.
 
1 - 9 of 9 Posts
Top