Kia Forum banner

1 - 11 of 11 Posts

·
Registered
2014 Kia Sorento--base trim level
Joined
·
8 Posts
Discussion Starter #1
Newbie here. About a week ago the ABS (anit lock brake system), ESC (electronic stability control), and Low Tire Pressure Indicator lights came on in my car. After some research, I've found that it is most likely the wheel sensor or the ABS module. Another weird tidbit that happened around the same time is that the radio controls on my steering wheel have been acting strange. For instance, the skip track button will now mute the radio or either switch it from radio to media. This usually corrects itself. My question is, is this in any way related to the indicator lights that are now on? (I saw a youtube video with a Toyota vehicle that said the ABS module was causing the same steering wheel radio button issues, but couldn't find anything related with Kia.) Also, is this something that can be repaired at home with a good tutorial and someone with some basic mechanic skills? My vehicle is no longer under warranty, so saving some money would be great. If so, how would one tell which sensor has malfunctioned? Any other tips or tricks would be greatly appreciated too. Thanks!
 

·
Registered
2014 Kia Sorento LX 2.4 l AWD
Joined
·
5 Posts
I’ve seen another thread talking about the steering wheel buttons acting up. The solution, it seems is to disconnect the battery for a few minutes. Then make sure the terminals are clean and reconnect the battery. This will essentially force a reboot of the computer that controls the functions. As for the dash lights, I have no answer to that one.
 

·
Registered
09 kia spectra ex,'11 Dodge Journey AWD,04 Chry. T&C, 08 Pontiac G6 gt
Joined
·
2,497 Posts
A bad tire pressure sensor in a wheel COULD activate the other lights(ABS,ESC). The programs to run them get readings from tire sensors to show that you don't have a Flat tire and would disable those systems IF you did. Have you checked the tire pressures manually or if equipped do all 4 tire positions indicate proper inflation?
 
  • Like
Reactions: Lou O.

·
Registered
Sorento 2015 LX 2.4 AWD, Suzuki 2011 SX4 AWD, ( 2000 KIA Sportage, junked)
Joined
·
500 Posts
Yes. As soon as low tire pressure is fired, everything else that goes with wheel speed is disabled too.
YOu did not mention if your car is AWD or not.
And steering wheel buttons are POS too. "normal problem".
 
  • Like
Reactions: Lou O.

·
Registered
2014 Kia Sorento--base trim level
Joined
·
8 Posts
Discussion Starter #5
I’ve seen another thread talking about the steering wheel buttons acting up. The solution, it seems is to disconnect the battery for a few minutes. Then make sure the terminals are clean and reconnect the battery. This will essentially force a reboot of the computer that controls the functions. As for the dash lights, I have no answer to that one.
Thank you! I'll def give this a try.
 

·
Registered
2014 Kia Sorento--base trim level
Joined
·
8 Posts
Discussion Starter #6
A bad tire pressure sensor in a wheel COULD activate the other lights(ABS,ESC). The programs to run them get readings from tire sensors to show that you don't have a Flat tire and would disable those systems IF you did. Have you checked the tire pressures manually or if equipped do all 4 tire positions indicate proper inflation?
I have, and the tire pressure was fine in all tires. I'm going tomorrow to my local tire center in hopes of getting it fixed. I just like to know as much as I can before hand. Thanks for your help!
 

·
Registered
Sorento SX AWD 2015
Joined
·
623 Posts
I doubt a low tire sensor would trigger all those other issues. I did no when my air was low in my own Highlander and it turned out to be the spare tire doing it!!! Maybe Kia doesn't put them in the spare but I have a full size aluminum spare and not a donut short term tire.

He needed to check for codes and maybe even a related fuse.
 

·
Registered
2014 Kia Sorento--base trim level
Joined
·
8 Posts
Discussion Starter #8
I doubt a low tire sensor would trigger all those other issues. I did no when my air was low in my own Highlander and it turned out to be the spare tire doing it!!! Maybe Kia doesn't put them in the spare but I have a full size aluminum spare and not a donut short term tire.

He needed to check for codes and maybe even a related fuse.
That is interesting and worth looking at for sure! I'm going to check that out when I get home. I appreciate the feedback.
 

·
Registered
Sorento SX AWD 2015
Joined
·
623 Posts
When ever I have removed a spare. I flip them and they fit still even with a hitch installed. Why, so the damm Air Valve is facing down!!!! I can check air pressure and top them up as they usually loose air over a year or two too low to work when needed.
 

·
Registered
USA 2015 Sorento EX V6 FWD (With authentic peeling pillars) 65k Miles
Joined
·
1 Posts
Newbie here. About a week ago the ABS (anit lock brake system), ESC (electronic stability control), and Low Tire Pressure Indicator lights came on in my car. After some research, I've found that it is most likely the wheel sensor or the ABS module. Another weird tidbit that happened around the same time is that the radio controls on my steering wheel have been acting strange. For instance, the skip track button will now mute the radio or either switch it from radio to media. This usually corrects itself. My question is, is this in any way related to the indicator lights that are now on? (I saw a youtube video with a Toyota vehicle that said the ABS module was causing the same steering wheel radio button issues, but couldn't find anything related with Kia.) Also, is this something that can be repaired at home with a good tutorial and someone with some basic mechanic skills? My vehicle is no longer under warranty, so saving some money would be great. If so, how would one tell which sensor has malfunctioned? Any other tips or tricks would be greatly appreciated too. Thanks!
I have this exact issue. Its the wheel bearing hub assembly. When checking the ABS codes, mine says wire fault/short. Calling the dealer to ask about repairs, I was told the hub itself is 50-100 dollars and its 550 out the door. I litteraly just got this car in Fevuary, didnt drive it for 6 months because of corona, and I get in it to have pretty much every light on the dash on.


Oh and my alternator and Battery both died at the same time, and Kia promises its not to do with the leaky ABS electrical fire hazard they just recalled last week.
 

·
Registered
Sorento SX AWD 2015
Joined
·
623 Posts
With it sitting that long and battery issues. Its more likely electrical. Clean and confirm the battery lugs as well as posts are clean. Reconnect and be sure to twist the cables lugs by hand to see if they twist/move on the post. Most after market batteries don't tighten on the posts and create a problem. Charge the battery before or after this. A very low battery may cause confusion in the Canbus communications. Resetting maybe needed.

It sounds like you not got anything tested and just talked to someone. Hence its a guess at best.
 
1 - 11 of 11 Posts
Top