Kia Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My wife and I bought a new 2013 Sorento about one month ago and we just had a strange experience a couple days ago.
We had just backed out of a parking stall and drove on down the road. We then noticed the rear view camera was still activated even though we were no longer in reverse. We could not do anything to shut the camera off and resume normal radio operation until we stopped a short time later. Our son, driving in a car behind us, told us the reverse lights were flickering as we drove in this condition.
After a couple miles we reached our destination and shut the vehicle off. After returning a short time later everything operated normally and we have not had the same thing happen again.
Anyone have this happen to them?
 

·
Registered
2013 Sorento LX V6, '03 GSX-R600, '00 Nissan Maxima SE
Joined
·
150 Posts
I haven't had that problem, or heard of it until now. Of course take it to your service center and have them check it out. We just got our Sorento about a month ago also, so any news of any possible problems would be appreciated.
 

·
Registered
Kia Sportage
Joined
·
2 Posts
the rearview picture o radio was controlled by the reversing cable from radio. Check that cable if it is loosen
 

·
Registered
2012 Sorento EX-V6 w sunroof, dark cherry
Joined
·
60 Posts
I had the same problem twice on my EX 2012. Both time I just pulled over and restart the vehicule.

Did not mentionned it to the dealer because once every 5 months isn't worth it.
 

·
Registered
Sorento SX 2013
Joined
·
237 Posts
very interesting to hear about this bug

will keep an eye in case it happens to my 2013 SX as well

Thanks for the heads up
 

·
Registered
2012 Titanium Silver Sorento LX w/ GDI
Joined
·
78 Posts
I had a recent issue with my rear view camera - the image flickered and then died completely. It was raining at the time. Next day I started it up again, but no image. Tried it again and all is good now. Anyone with this intermittent problem?
 

·
Registered
2012 Sorento LX, 2012 Sportage SX, 1989 Taurus SHO
Joined
·
289 Posts
I had the same thing happen to my 2012 Sportage twice. First time it was raining (more than a year ago) and the second time a few months ago on a clear and nice day. The back up camera was fine after the engine was shut off and restarted.
 

·
Registered
SORENTO 2012 V6 EX AWD SUNROOF MOONROOF
Joined
·
116 Posts
Get the dealer as soon as you can.
One of your reverse sensors could be faulty, might not only be your camera thats affected.
The cars computer makes a lot of decisions based on sensor positions.
Even if it is only every 6 months, you don't want something jamming up while you're on a road trip.
Chances are its nothing serious and easily fixed, best safe than sorry.
 

·
Registered
2015 Kia Sorento SX Regency Red, 2012 Kia Sorento SX, 2011 Toyota Hiace
Joined
·
573 Posts
What's bugging me with the rearview cam is that it also captures a bit of the SX's bumper and even a tiny bit of my license plate! So it only displays like 95% of the view.
I know it's kinda small deal but still..

I mean, come on Kia. You can do better than that in aiming the camera for the perfect angle and view.
 

·
Registered
2011 Sorento AWD V6 SX Cherry Black
Joined
·
231 Posts
Heard that KIA has a replacement call back on some rear cameras. Just have the dealer check it out, under full warranty in any case.
 

·
Registered
SORENTO 2012 V6 EX AWD SUNROOF MOONROOF
Joined
·
116 Posts
What's bugging me with the rearview cam is that it also captures a bit of the SX's bumper and even a tiny bit of my license plate! So it only displays like 95% of the view.
I know it's kinda small deal but still..

I mean, come on Kia. You can do better than that in aiming the camera for the perfect angle and view.
When I first noticed that, I thought the camera had malfunctioned, (I did not know what the black was) after doing some research I found out its not only KIA, almost every manufacturer is the same, its the wide angle Lens design.
Some manufactures hide this area, however I'd imagine it could be useful if you're backing-up to high parking barriers.
Or how many of you have backed up over your suitcases!

The biggest wish I have is the ability to turn the Cam on while driving forward.
 

·
Registered
2013 Kia Sorento EX V6 Luxury
Joined
·
89 Posts
When I had my 2012 EX, the same thing happened once. I restarted the Sorento and it was ok, I had the UVO which was cool but buggie.
 

·
Registered
2014 Sorento LX 2.4 GDI
Joined
·
29 Posts
No problems with rear view camera on a 2014 LX even after driving through 3 to 5 inches of slushy snow for an extended period of time.
 

·
Registered
Bronze 2012 Sorento EX V6
Joined
·
14 Posts
I experienced this for the first time about a month or so ago as well. 2012 EXv6. I don't remember the specifics but I think the Uvo Was booting up when I put it in reverse, and when it finished, it went to the camera as I was putting it into drive. It was interesting to see the rear view on the screen, but no radio either. Has not happened since.

I also had an episode shortly after I got the vehicle on a rainy day where the UVO wouldn't start up, and the screen stayed black. Fortunately I have not see that happen again either. I need to remember to have them check it next oil change. Just had it done too.
 

·
Registered
Sorento
Joined
·
1 Posts
Camera not working

Try this - turn your headlights on and the camera starts working. you can then turn the lights off. So far that has worked for me every time - go figure! BTW - I have the camera in the rear view mirror.
 
1 - 16 of 16 Posts
Top