Kia Forum banner

1 - 5 of 5 Posts

·
Registered
2013 Kia Sorento LX 2.4liter
Joined
·
2 Posts
Discussion Starter · #1 ·
Just recently my Sorento started to have issues. The car would lurch, engine light blink while driving on the freeway and all would go away and seem to be okay. Then later it happened again while accelerating to get on the freeway and the car lost power, rpms went to nothing and I had no acceleration or power. Turned car off and restarted it and everything worked. This is a 13 Sorento lx with the 2.4l. Has 184500 miles. I change the oil using synthetic oil and premium filters. I’ve had the trans fluid flushed, and all the Kia recalls and such. Kia disavowed knowing of any issues for this. They said they couldn’t find the issue. Is this a bad cam or crank sensor?
 

·
Registered
Sorento 2012
Joined
·
216 Posts
Just a total guess, because you offer no diagnostic information, is that it may be a crankshaft position sensor that is failing but it could be something else too. You need to read the stored ECM codes to see why the "Check Engine" light was blinking.
 

·
Registered
White 2012 SX AWD
Joined
·
810 Posts
Another note about a "blinking" check engine light...it means there is a SEVERE issue occurred. I read that one reason is a cylinder misfire...not sure. However, a failing crankshaft position sensor may be severe enough for a misfire or other issues to happen. Best bet is to read the codes and then go from there, as jolt2 said.
 

·
Registered
2013 Kia Sorento LX 2.4liter
Joined
·
2 Posts
Discussion Starter · #4 ·
Since the light went away, there aren’t any codes listed when using an obd reader. I’ve already replaced the plugs ‘with proper gap’ and the coil packs. No change. I also had the dealership look and they said there aren’t any codes being thrown. So until the light comes on and stays on, I’m out of luck on the code side.
 

·
Registered
White 2012 SX AWD
Joined
·
810 Posts
I changed my crankshaft position sensor. Symptoms were a little different from yours but some similarities. I was able to read a P0335 code but only once. I have a 3.5l

Here's a thread about the 2.4l crankshaft position sensor:


Best to diagnose, though.
 
1 - 5 of 5 Posts
Top