Kia Forum banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
2011 Sorento 2.4L & 2012 Optima Premium Hybrid, 1989 KR-1 250cc "2stroke"
Joined
·
103 Posts
Discussion Starter #1
yes, title says it all.

i just want to share what i encountered with my brandnew 2012 optima hybrid premium package with 1100 miles..

We start it one morning and suddenly the (1) malfunction icon and (2) check engine light popped up, and in the dashboard it appeared "PLS STOP THE VEHICLE RIGHT AWAY AND DONT DRIVE IT" something like that and then called the towing company to bring it at the dealer then after a day the dealer called us saying they need to replace the TRANSMISSION?! then after a week the transmission was replaced and after they test drive it theres still a malfunction on the computer so they said they might change the whole wiring of the hybrid, for a thousand miles???

anyway, everything is free and the kia staffs are keeping us posted everyday, im sharing this problem of mine to know if anyone also encountered this kind of problem or someone of you might give us an idea what really happened... i still love our KIA Optima Hybrid and missing it right now. its been in the dealer for almost 2 weeks T_T
 

·
Registered
2011 Kia Optima LX 2011 Kia Sorento SX
Joined
·
142 Posts
WoW dude, good thing the cars under warranty eh?
 

·
Registered
Joined
·
108 Posts
So they diagnosed a complete transmission swap (huge labor paid by the manufacturer) and after completion it was still doing the same thing? Clearly the initial diagnosis was wrong. Changing out a wiring harness on a brand new vehicle? Whiskey Tango Foxtrot? Me thinks your technicians don't know what the hell they're doing.
 

·
Registered
2011 Optima SX, Tech & Premium Touring
Joined
·
570 Posts
Wow, not good. Are they providing you with a loaner?
 

·
Registered
2011 Sorento 2.4L & 2012 Optima Premium Hybrid, 1989 KR-1 250cc "2stroke"
Joined
·
103 Posts
Discussion Starter #6
WoW dude, good thing the cars under warranty eh?
yup! thats the good thing the car is still under the warranty or else i dont know what to do...

That sucks, I got one exactly like yours, only 2011. Hope they take care of the problem.
yeah man, they actually took good care of the problem and to us by giving us a free rental car for 16days and updating us everyday (weekdays)...
 

·
Registered
2011 Sorento 2.4L & 2012 Optima Premium Hybrid, 1989 KR-1 250cc "2stroke"
Joined
·
103 Posts
Discussion Starter #7
So they diagnosed a complete transmission swap (huge labor paid by the manufacturer)
yes, at first they said the computer was telling them that there is a Transmission problem which they need to replace for a "1100 miles car".. (big money here)

So they diagnosed a complete transmission swap (huge labor paid by the manufacturer) and after completion it was still doing the same thing? Clearly the initial diagnosis was wrong. Changing out a wiring harness on a brand new vehicle?
thats what we also thought, probably they diagnose it wrong (maybe), then later on the Main KIA Company from Georgia called us, they said the problem of our vehicle took their attention (im from Louisiana) because the dealer here cant fix it... then after a few days they said they need to replace the whole wiring harness for the hybrid...

Whiskey Tango Foxtrot? Me thinks your technicians don't know what the hell they're doing.
thats on my mind too, for a brandnew vehicle with 1100 miles...
 

·
Registered
2011 Sorento 2.4L & 2012 Optima Premium Hybrid, 1989 KR-1 250cc "2stroke"
Joined
·
103 Posts
Discussion Starter #8

·
Registered
2011 Sorento 2.4L & 2012 Optima Premium Hybrid, 1989 KR-1 250cc "2stroke"
Joined
·
103 Posts
Discussion Starter #9 (Edited)
Result..

Finally the result is here..
this is what they told me at the dealer and the invoice is also below..

they told us that they replaced the ff:
- Transmission
- Complete Wiring Harness for the Electric (Hybrid)
- Some kind of Computer...
our hybrid stayed at the dealer for 17 days but didnt change our mind in loving KIA vehicles, they provided us a FREE car rental for 16 days, updating us everyday on the problems and results and even cleaned our vehicle when we picked it up. LoL. i know its not a minor problem but im still glad its still in warranty so everything is FREE, right now.... Drive Safe Everyone!!

INVOICE:
 
  • Like
Reactions: Brenders

·
Registered
2011 Kia Optima LX 2011 Kia Sorento SX
Joined
·
142 Posts
ugh just thinking about all that not under warrenty is probably would've cost 1/5 or 1/4th of the car...
 

·
Registered
Accord, stick
Joined
·
206 Posts
You should get new car and let KIA figures out what was wrong with your car (or the whole Hybrid series)...
Why are you SO EXCITED getting FREE loaner? You should! It is their fault you are without car for 17 days... Dealer could give you even any demo for your use (you pay gas).
 

·
Registered
2012 Optoma Hybrid (Light graphite)
Joined
·
169 Posts
Just purchased one of these hybrids today. Traded in my trusty RIO. I got the light graphite with the convenience package. Won't get to drive it for a few weeks. It is still in transit from Korea...bummer. Test drove the EX and Hybrid today. I like the solidity of the Hybrid on the road. It reminds me of my former Jag s-type in the weighty feel on the highway. What an extremely quiet vehicle! The demo vehicle I drove blew my mind in town. It felt like we were coasting all over town! :lol:
 

·
Registered
2014 Optima SXL
Joined
·
92 Posts
Doesn't look like there was a whole transmission swap. Per write up it seems like there was a short in the wiring harness. I doubt the whole harness was replaced. It took this look probably because they couldn't diagnose the problem and had to wait for the specialist to fly in.
 

·
Registered
Joined
·
2 Posts
I'm having the same malfunction indicator light issue. I have a 2012 Kia Optima EX w/premium pkg; I purchased my car April 2012. I've taken my car to CarPros in Carson, CA for the third time since the purchase of my car. This post was quite helpful. I'll be referencing this situation to the service manager. Thank you for posting.
 

·
Registered
Joined
·
2 Posts
2013 Optima Hybrid: Pls stop the vehicle right away and dont drive it

2013 Optima Hybrid EX purchased September 7, 2013
Car stalled with same message, towed to dealer on October 5, 2013 with 1600 miles.
Kia of Cerritos: FOUND HISTORY CODE P0AZ8 IN SYSTEM, CLEARED CODE TEST DROVE UNDER ENABLED CONDITIONS, AND CODES NEVER CAME BACK ON AS OF NOW. NO FURTHER ACTION REQUIRED.
Picked up the car on October 8, 2013 and no error messages as of week later.
Does anyone know what that code means?
Separate issue: Took the car back to dealer for broken right rear window down button, going back the the dealer to replace with new part.
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top