Kia Forum banner

1 - 2 of 2 Posts

·
Registered
2012 optima hybrid, 2002 avalanche, 1951 chevrolet coupe, 1951 chopped merc
Joined
·
1 Posts
Discussion Starter #1
Hello all,
New to this forum and to the Kia world.
Question is I have had the car for 5000kms now and when the ECO mode is on it seems to hold 5 th gear at 60 miles and hour -100k till I ride to 110 or so feeling like something is straining or being held back. And the fuel economy is crappy...or not as the sold it to me. I get 7.8 litres to 100 kms.
When I remove the ECO mode it seems to release the tension on the car (feels free-er so to speak) and I register 5.8-6.0 liters to 100 kms:confused:
Isn't the ECO supposed to be better fuel economy?? Dealer said no dtc's and all seems normal on the obd2 side that I need to drive the hybrid like a hybrid...but I am its just better off ECO (thought it was a stupid response on thier part)...but I know and feel and see the difference....anyone else notice this....try it ...drive at 60 miles an hour on ECO and stay steady on the pedal...turn it off and feel the difference...or is it only my car??

Also any one experience the climate control all of sudden going to auto defrost mode and not being able to come out manually? mine does and again they say all is normal because it never happened while they check it.
Thanks for all input....cheers!
 

·
Registered
Cerato S Hatch Auto
Joined
·
1,236 Posts
5th or 6th at 100 km/h?. That's normal for the average sort of car. Shouldn't feel strange, though. There have been various complaints about ECO mode, from poor performance to bad fuel consumption to "doesn't do anything". Just turn it off if you can get better fuel consumption without it, a figure of 5.8 litres/100 km is very good.

ECO is just a dumb Greenie mantra like "Organic" or "Anti-Oxidant". Some sales guy at KIA thought it would be a good idea.
 
1 - 2 of 2 Posts
Top