Kia Forum banner

1 - 20 of 29 Posts

·
Registered
2012 Kia Sorento, 2006 Acura RSX-S, 2004 Mazdaspeed Miata
Joined
·
3 Posts
Discussion Starter #1
I purchased my 2012 Kia Sorento EX V6 AWD a couple of weeks ago, this is my first Kia. Twice over the last couple of weeks the push button start has failed to start the car. It Cranks and Cranks, but the engine won't fire. After about 5-7 seconds of cranking, I pushed the button again to make it stop. Then Pushing the button a second time results in a successful start-up, as though nothing at all was wrong. The behavior has been the same both times, second try = starts up no problem.

I've attempted to do some research on this issue myself but haven't come up with anything that fits. Most of the other threads about Push button no-start issues are related to the brake or parking switch, which if I'm understanding those issues correctly, result in nothing at all happening (no cranking). Mine cranks, but won't start on the first try. Has anyone experienced anything like this or have some additional info?

I'm planning to take it to the dealership tomorrow, but I'd like to have something to point them towards. Since it is an intermittent problem, I'm sure it won't do it when they have the car... :(

Thanks!
Jeremy
 

·
Registered
2011 Kia Sorento EX V6 AWD & 2010 Hyundai Sonata SE
Joined
·
532 Posts
Are you hearing your interior and exterior chime on solid while it's cranking?
 

·
Registered
2012 Kia Sorento, 2006 Acura RSX-S, 2004 Mazdaspeed Miata
Joined
·
3 Posts
Discussion Starter #3
Hi, thanks for the reply. No, I only hear engine cranking.

After you push the start button, if the car fails to start, will the cranking eventually stop on its own after a timeout period?

What I haven't done yet, is allow the process to continue uninterrupted. The 2 times that It happened so far, I got freaked out and pushed the button again to stop it. A second push of the button resulted in immediate successful startup.

I think I need to figure out if it will really fail to start, or if its just taking abnormally long to start, and I haven't been patient enough yet to determine that.

Thanks again!
Jeremy
 

·
Registered
2011 Kia Sorento EX V6 AWD & 2010 Hyundai Sonata SE
Joined
·
532 Posts
Mine stops after approximately 10 seconds. But with mine it's a constant beep inside and outside while it's cranking. It's triggering the Anti-Theft system.

It's happened to me several times now...but hasn't done it for months. It's completely random.

Next time it happens to you, let it crank until it stops on it's own. If you get lucky, the computer will store some sort of code that the dealer can use to track down what's going on.
 

·
Registered
2015 Sedona EX - Premium Package
Joined
·
737 Posts
It maybe from its brake switch or FOB key which included in its security system. Well, it happens to me once or maybe twice. Try to check your battery, if it's low charge or almost dies it goes like that. I hope this will help though this is a long shot solution.
 

·
Registered
2012 Kia Sorento, 2006 Acura RSX-S, 2004 Mazdaspeed Miata
Joined
·
3 Posts
Discussion Starter #6
Update:
Same thing just happened again today, this is the 3rd time in my 4 weeks of ownership. Here's what I know after paying closer attention:

Car was completely in Park.
Key was inside the vehicle.
Brake was depressed completely.

Pushed the button, car cranked for 10 seconds but did not start. It cranked at a normal pace, not as though the battery was low. No beeping heard inside or outside, the key light wasn't lit on the dash. It cranks as though there is either no fuel or no spark. It doesn't sputter or cough or try to fire at all.

After 10 seconds of cranking, it stopped. I then changed nothing, pushed the button again and the car fired right up. Out of the 3 times this has happened, the car has always started on the second try.

Its going to the dealership tomorrow. Now that I know it has done it recently, hopefully there will be a stored code for them to pull.

Thanks!
Jeremy
 

·
Registered
2011 Kia Sorento EX V6 AWD & 2010 Hyundai Sonata SE
Joined
·
532 Posts
Hope and pray to god they can duplicate it. This is one of those problems that will leave you with a headache because they will keep returning it saying they can't duplicate the problem. Good luck and keep us updated!
 

·
Registered
2013 Sorento, Suzuki V-Strom
Joined
·
506 Posts
Make a video. You might have a lot of vids that show you starting successfully that you can discard, but it only takes one to show the failure.
 

·
Registered
2012 Sorento SX
Joined
·
31 Posts
Have you heard anything back from the dealership? Mine did this for the second time this weekend. It has probably been two months between the indidents...
 

·
Registered
2012 Kia Sorento SX, 2003 Honda S2000
Joined
·
183 Posts
Mine does this once every few months, it's hard to get a video of because you never know when it's going to happen and I'm certainly not going to start video taping every time I start my car. Please let us know if your dealership is able to track it down since yours happens more frequently, maybe we can relay the information to our dealerships :)
 

·
Registered
White 2012 SX AWD
Joined
·
760 Posts
Maybe there's a code stored that you can read. It's a longshot, but maybe.

If you or someone you know has an OBD II reader, it's super easy to check.

Dealer might or might not have done this.
 

·
Registered
Rip 04 nissan sentra 07 honda fit sport trade in now my new 2011 Kia sportage
Joined
·
32 Posts
I'm still having this issue, very intermittent. Anyone?
Got 2011 Kia sportage brake switch replace 5x random not start keeps crank not start 2nd time start up no problem any one test the fuel pump
 

·
Registered
Joined
·
265 Posts
I would have them replace the CPS (crank position sensor).. the car does not know where the #1 piston is and won't fire.
 

·
Registered
2015 Sedona EX - Premium Package
Joined
·
737 Posts
Did you fellas heard about ETC? Electronic Throttle Control? According to my research, this needs to be cleaned once every year before winter hits. Throttle body accumulates gunk, gums and dust when not cleaned during winter especially in places with negative wind chills or temp near 0 deg, it will froze to stuck some of mechanical component of the said system and triggers problems like,the ff:

1) hard starting
2) starts but very low idle and rough, starts illuminates the 4x4 locking and engine check on,
3) gas pedal depressed, not responding.

I will cleaned it out tomorrow before she will totally unmovable.
 

·
Registered
2015 Sedona EX - Premium Package
Joined
·
737 Posts
follow up for throttle body cleaning.

When I remove the air duct connected to the TB, I found it clean but the edge of the plate has gum and behind(other side) it was horribly black. Gum is sticky and made the plate gap more than normal. So what I did, I remove the TB and cleaned it thoroughly and making sure things is in order returning it. Now, super smooth acceleration and the idle is back to normal. Like new. It's worth a try. :)
 
1 - 20 of 29 Posts
Top