Kia Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello,

I bought a new Kia Forte 2012 around 1 1/2 ago and the radio at the time worked great for about the first week. When I plugged in my IPhone 4 through the USB/aux jack that comes with the car, the radio would give this screeching sound after about 30 minutes of driving, it started yelling that there wasn't a phone paired or selected (in french), and the CD player would not accept a cd but would display the "loading cd" message. I brought the car back to be serviced and they said the radio was defective and they had to replace it. The radio was replaced and about 2 months later I tried to put in a cd. The cd worked great except when I tried to eject it, the cd wouldn't come out. So they went ahead and "reset" the radio. Well this has happened twice since the radio was supposably replaced. The screeching sound has now come back after I bought a new IPhone and tried to plug it in. One additional problem has started as well, the radio now clicks almost like you have the turning signal on. These clicks start about 5 minutes into the drive with or without the radio turned on and the screeching starts about 20-30 only if the iPhone is plugged in. The cd has again stopped working. I've just exceeded the warranty on it but the service rep still looked at it because I have had an existing problem. Now I'm told that they don't know what's causing it but the service tech recommends another replacement radio. Has any heard of or experienced this problem yet? Any assistance would greatly be appreciated.
 
1 - 1 of 1 Posts
Top